Support » Fixing WordPress » WordPress now replaces the quotes ” ” with « »

  • Hello,

    Since yesterday, perhaps due to some WordPress update I have seen that the default WordPress quote changed, that is:

    I published a similar title and/or content like this:

    Example 1: Lorem ipsum dolor sit amet, consectetur “adipiscing elit” (quotes without curves)

    And before WordPress changed it to double quotes like this:

    Example 2: Lorem ipsum dolor sit amet, consectetur “adipiscing elit”

    That was fine for us, but since yesterday WordPress by default leaves it like this with guillemets:

    Example 3: Lorem ipsum dolor sit amet, consectetur «adipiscing elit»

    And it’s bad for us, we want not guillemets, because we handle double curves of this type curved: “”

    I attach an image so that my problem is better understood, click here

    How could I fix this?, because it also affected articles published in the past.

    Thanks in advance.

Viewing 7 replies - 1 through 7 (of 7 total)
  • I’m experimenting the same issue in my website (www.nolapeles.com). How can we fix this issue? I don’t want wordpress to replace quotation marks with guillemets.

    Hi Carlos,

    I just find the solution. Just go to settings and change the wordpress language from Spanish to any other Spanish set. For example, use Spanish from Mexico or Spanish from any other country instead of the standard Spanish option.

    I hope this helps you solve your problem.

    Saludos!

    Dion

    (@diondesigns)

    If you add the following line to your theme’s functions.php file, WordPress will stop changing those characters and your content will display as written:

    add_filter('run_wptexturize', false);
    

    Thanks @echezuria , it worked to change the language. 🙂

    The good way to do it is to set to false the wptexturize filter in your functions.php

    add_filter('run_wptexturize', '__return_false');

    Like this, you can set any language you want.

    • This reply was modified 1 year, 6 months ago by patrice.

    How to create quotes like this website

    https://www.attitudestatus.org/

    plz explain how to create for this website

    my website

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘WordPress now replaces the quotes ” ” with « »’ is closed to new replies.