Support » Fixing WordPress » WordPress not showing site icon

  • ttjgbg

    (@ttjgbg)


    I have uploaded a site icon and it used to work. It shows when using a browser but when sending a link to my webiste through whatsapp for example. The preview is some logo I have in my media files. I have cleared cache. I think I worked on something a while ago but cant remember because it used to show the right icon before

    The page I need help with: [log in to see the link]

Viewing 5 replies - 1 through 5 (of 5 total)
  • SJW

    (@whitsey)

    Looks like you have Yoast installed which determines the image per page that is shared to other sites.
    Check the Yoast page settings – this will be the image that is “shared” and not the site icon.
    https://yoast.com/advanced-technical-seo-social-image-ogimage-tags/

    ttjgbg

    (@ttjgbg)

    I found the unwanted picture in Search Apperance. I changed it to the one I wanted. I tried to read and did not see how long time for the change to update. I tried to send through different browsers but still the same unwanted picture even though I changed. Do you know if it’s take time before it’s updated?

    It can take time.

    Facebook and twitter provide tools for testing:

    https://developers.facebook.com/tools/debug/
    https://cards-dev.twitter.com/validator

    Ok, nice with the tools. I see that I
    still have the unwanted logo even though I changed it.
    Nothing has changed.

    The og:image property in your webpage code is showing: https://loveyourcaps.com/wp-content/uploads/2019/11/backgroundwebsite-1024×246.jpg
    This is the default sharing image.
    Not sure what you’re expecting as you haven’t said but this is what is set in your page:

    <meta charset="UTF-8" />
    <meta name="viewport" content="width=device-width, initial-scale=1" />
    <meta name="description" content="A Collection of Vintage caps in one place. Retro caps, Worn Caps, Baseball caps, Trucker caps and Snapback caps. FREE GLOBAL SHIPPING!" />
    <meta name="robots" content="max-snippet:-1, max-image-preview:large, max-video-preview:-1" />
    <meta property="og:locale" content="en_US" />
    <meta property="og:type" content="website" />
    <meta property="og:title" content="LoveYourCaps | Find Your Cap!" />
    <meta property="og:description" content="A Collection of Vintage caps in one place. Retro caps, Worn Caps, Baseball caps, Trucker caps and Snapback caps. FREE GLOBAL SHIPPING!" />
    <meta property="og:url" content="https://loveyourcaps.com/" />
    <meta property="og:site_name" content="LoveYourCaps" />
    <meta property="og:image" content="https://loveyourcaps.com/wp-content/uploads/2019/11/backgroundwebsite-1024x246.jpg" />
    <meta property="og:image:secure_url" content="https://loveyourcaps.com/wp-content/uploads/2019/11/backgroundwebsite-1024x246.jpg" />
    <meta property="og:image:width" content="1024" />
    <meta property="og:image:height" content="246" />
    <meta name="twitter:card" content="summary_large_image" />
    <meta name="twitter:description" content="A Collection of Vintage caps in one place. Retro caps, Worn Caps, Baseball caps, Trucker caps and Snapback caps. FREE GLOBAL SHIPPING!" />
    <meta name="twitter:title" content="LoveYourCaps | Find Your Cap!" />
    <meta name="twitter:image" content="https://loveyourcaps.com/wp-content/uploads/2019/12/backgroundwebsite-scaled.jpg" />
    <meta name="google-site-verification" content="9vzUet7z7HO1MPoG10FPw4VoqWbd9kRbfnymSwHqSFQ" />
    <meta name="yandex-verification" content="771a64f308c3445d" />
    <meta name="generator" content="WordPress 5.4" />
    <meta name="generator" content="WooCommerce 4.0.1" />
    <meta name="msapplication-TileImage" content="https://loveyourcaps.com/wp-content/uploads/2019/07/cropped-512-270x270.jpg" />
    • This reply was modified 6 months, 3 weeks ago by SJW.
Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘WordPress not showing site icon’ is closed to new replies.