WordPress.org

Support

Support » How-To and Troubleshooting » WordPress not sending emails

WordPress not sending emails

  • Hello,

    I’ve been troubleshooting this all day – reading various blogs and message posts on it. I’m currently hosted at godaddy, and though various advice I have installed the WP-Mail-SMTP and followed this guys instructions:
    http://www.angstrey.com/index.php/2009/04/22/how-to-send-e-mail-with-wordpress-from-godaddy-windows-hosting/

    I was excited at first because I indeed got the (bool = true) and thought it was fixed. I’ve sent test emails successfully, but the “Contact 7” that I installed does not work – nor do emails that are supposed to notify me of comment updates. I’m not sure if the problem is related to either, but I wanted to figure out why WP isn’t sending me email notifications first. I’ve got the appropriate email address in the GENERAL SETTINGS and the USER SETTINGS for admin.

    If I were a little more advanced I might be able to fix this, but I’m afraid I’ve reached my ceiling here. Any ideas?

Viewing 7 replies - 1 through 7 (of 7 total)
  • Hi,

    It depends on your hosting server configuration and SMTP settings. To overcome from that you can use these plugins to send email from the wordpress blog:

    http://wordpress.org/extend/plugins/wp-email/
    http://wordpress.org/extend/plugins/email-users/

    Thanks,

    Shane G.

    I host my WordPress sites on the Rackspace Cloud (formerly known as Mosso) and in order to get the email notifications from WordPress to send, I had to add the following line to a .htaccess file in the document root of the website.

    # PHP - MAIL
    php_value mail.force_extra_parameters -fwebmaster@example.com

    Of course you’ll have to change the “webmaster@example.com” to something relevant to your website, but you get the picture. Hope this helps your situation.

    hi,

    i was also facing same problem and it took almost 1 week to solve it.

    Here is the solution

    [link moderated]

    I was having same problem. There is nothing wrong with WordPress scripts nor with Contact Form Plugin. Its all with your localhost setting in C-panel.

    Its all due to MXentry setting problem in your website c-panel.

    [link moderated]

    Kevin Subba,
    What is and where do i find the C-panel?

    Thank you,
    David

    Caliparti, did you ever resolve this issue? I am having the same one and am looking for a solution.
    Thanks

    adding the # PHP – MAIL
    php_value mail.force_extra_parameters –
    crashed the site..

    Use “WP Mail SMTP” this plugin will fix everything i had the same problem and now everything is ok.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘WordPress not sending emails’ is closed to new replies.