Support » Plugins and Hacks » WordPress needs to access my web server error?

  • Recently some of my plugins on my dashboard state that there is a new version of it. If gives me the option to upgrade automatically and when I click on the link to upgrade I get the following:

    To perform the requested action, WordPress needs to access to your web server. Please enter your FTP credentials to proceed. If you do not remember your credentials, you should contact your web host.

    Why am I getting this error? I’ve never got this message before.

Viewing 5 replies - 1 through 5 (of 5 total)
  • I’m getting the same error when trying to upgrade to the latest version of WordPress (3.0.4).

    The general way of procedure is to Never give Anyone that information Ever, why is (WordPress) asking for sensitive info like this ?Un-cool

    esmi

    (@esmi)

    Forum Moderator

    Because it would normally be able to install without it but your server is configured in such a way that it cannot. If you don’t want to type the details into your own site, you will need to install plugins & themes manually – as well as upgrade manually.

    But I have not changed anything on my server. and the info is being requested by wordpress not by “my own site” my server knows its name and passwords or else I would not be logged in ? also if you mean manually as in ftp it is not working either (since upgrade)? why would WP. change my ability to upload files and how ?

    esmi

    (@esmi)

    Forum Moderator

    But I have not changed anything on my server

    Then check with your hosts to see if they have changed anything on your server.

    the info is being requested by wordpress not by “my own site”

    Your copy of WP on your site.

    my server knows its name and passwords or else I would not be logged in

    File transfer needs ftp credentials – not a login for your dashboard.

    also if you mean manually as in ftp it is not working either (since upgrade)?

    That has absolutely nothing to with WordPress. Try contacting your hosts.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘WordPress needs to access my web server error?’ is closed to new replies.