Support » Fixing WordPress » WordPress mySQL error on phpMyAdmin 2.5.6

  • Resolved Smith

    (@ikaspars)


    Hello, guys.

    I am trying to import a wordpress database to other server, but that server have old phpMyAdmin 2.5.6 version.

    When I am importing that database I am getting error :#1064 – You have an error in your SQL syntax near ‘SQL_MODE=”NO_AUTO_VALUE_ON_ZERO”‘ at line 1

    When I comment that line out, I get another error.

    Is there any way to get it work on this server?

Viewing 3 replies - 1 through 3 (of 3 total)
  • 123milliseconds

    (@123milliseconds)

    >>>I get another error.

    and it is …

    Your host SQL version is lower than the SQL version at the host where you did the export

    try exporting is csv format; NOT as sql statements

    Smith

    (@ikaspars)

    When I comment out that firs line I get this error :

    SQL-query : 
    
    CREATE TABLE  <code>wp_commentmeta</code> (
    
     <code>meta_id</code> BIGINT( 20 ) UNSIGNED NOT NULL AUTO_INCREMENT ,
     <code>comment_id</code> BIGINT( 20 ) UNSIGNED NOT NULL DEFAULT  '0',
     <code>meta_key</code> VARCHAR( 255 ) DEFAULT NULL ,
     <code>meta_value</code> LONGTEXT,
    PRIMARY KEY (  <code>meta_id</code> ) ,
    KEY  <code>comment_id</code> (  <code>comment_id</code> ) ,
    KEY  <code>meta_key</code> (  <code>meta_key</code> )
    )ENGINE = MYISAM DEFAULT CHARSET = utf8 AUTO_INCREMENT =1
    MySQL said:
    #1064 - You have an error in your SQL syntax near 'ENGINE=MyISAM DEFAULT CHARSET=utf8 AUTO_INCREMENT=1 ' at line 9

    I tried to save as CSV and i got this error –

    MySQL said:
    #1064 - You have an error in your SQL syntax near '"1"' at line 1
    Smith

    (@ikaspars)

    Thanks, I fixed it.

    I used a SQL compatibility mode – MYSQL323

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘WordPress mySQL error on phpMyAdmin 2.5.6’ is closed to new replies.