WordPress.org

Support

Support » Multisite » [Resolved] WordPress Multisite on Azure: Issue accessing wp-admin

[Resolved] WordPress Multisite on Azure: Issue accessing wp-admin

  • I’m using Microsoft’s Azure hosting (so Windows not Linux)and I’m having trouble with the Multisite installation. I’ve installed WordPress 3.5.1 (using the Azure wizard) and this worked fine and as expected. Then I added in the Multisite code, setup my network to use subfolders (subdirectories), and followed the instructions to modify the web.config and wp-config files. Finally, I created my additional network sites through the “Add New Site” interface. I can access all of the subdirectory sites. However, I can’t get to the wp-admin dashboard of any of the new sites. In other words, I can access mydomain.azurewebsites.net/example but not mydomain.azurewebsites.net/example/wp-admin. When I try, I get “The resource you are looking for has been removed, had its name changed, or is temporarily unavailable.” (Or basically a 404 error).

    I followed these instructions: http://www.windowsazure.com/en-us/develop/php/tutorials/convert-wordpress-site-to-multisite/ and tried searching, but can’t figure it out.

    Any suggestions?

Viewing 3 replies - 1 through 3 (of 3 total)
  • Figured it out – it was the web.config file. If anyone else runs into this, here was the fix that worked for me:

    <?xml version=”1.0″ encoding=”UTF-8″?>
    <configuration>
    <system.webServer>
    <rewrite>
    <rules>
    <rule name=”WordPress Rule 1″ stopProcessing=”true”>
    <match url=”^index\.php$” ignoreCase=”false” />
    <action type=”None” />
    </rule>
    <rule name=”WordPress Rule 2″ stopProcessing=”true”>
    <match url=”^([_0-9a-zA-Z-]+/)?files/(.+)” ignoreCase=”false” />
    <action type=”Rewrite” url=”wp-includes/ms-files.php?file={R:2}” appendQueryString=”false” />
    </rule>
    <rule name=”WordPress Rule 3″ stopProcessing=”true”>
    <match url=”^([_0-9a-zA-Z-]+/)?wp-admin$” ignoreCase=”false” />
    <action type=”Redirect” url=”{R:1}wp-admin/” redirectType=”Permanent” />
    </rule>
    <rule name=”WordPress Rule 4″ stopProcessing=”true”>

    <match url=”^” ignoreCase=”false” />
    <conditions logicalGrouping=”MatchAny”>
    <add input=”{REQUEST_FILENAME}” matchType=”IsFile” ignoreCase=”false” />
    <add input=”{REQUEST_FILENAME}” matchType=”IsDirectory” ignoreCase=”false” />
    </conditions>
    <action type=”None” />
    </rule>
    <rule name=”WordPress Rule 5″ stopProcessing=”true”>
    <match url=”(^[_0-9a-zA-Z-]+/)?(wp-(content|admin|includes).*)” ignoreCase=”false” />
    <action type=”Rewrite” url=”{R:2}” />
    </rule>
    <rule name=”WordPress Rule 6″ stopProcessing=”true”>
    <match url=”^([_0-9a-zA-Z-]+/)?(.*\.php)$” ignoreCase=”false” />
    <action type=”Rewrite” url=”{R:2}” />
    </rule>
    <rule name=”WordPress Rule 7″ stopProcessing=”true”>
    <match url=”.” ignoreCase=”false” />
    <action type=”Rewrite” url=”index.php” />
    </rule>
    </rules>
    </rewrite>
    </system.webServer>
    </configuration>

    What exactly was your fix? Did you grab an initial set of rewrite rules from somewhere specific? I found some here: http://core.trac.wordpress.org/ticket/23748

    But they differ from yours in 3 different places. Do your blogs.dir rewrite rules also work with the above configuration?

    Thanks,
    Dave

    Thanks ribbitfrog its did the trick for me, thanks again guys.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘[Resolved] WordPress Multisite on Azure: Issue accessing wp-admin’ is closed to new replies.