[closed] WordPress Multisite Login Loop Fixed (7 posts)

  1. flip_this
    Posted 4 years ago #

    I've been having an absolute bear of a time trying to figure out why I would get a login loop when trying to log into a wordpress multisite subdomain/subsite.

    I finally figured out that when I went to map a domain to the new site i was putting in the wrong site id. In the latest update they removed the column that shows what the site ID is. I assumed that you just counted how many sites you have and however far down on the list it was denoted the site ID. If you hover your mouse over the site name in the sites list it will display the site ID then.

    This is what worked for me and if i explained it wrong and anyone needs clarification please feel free to ask.

  2. You did it awesome :D

    If you'd like a plugin to put the column back, there's one here: http://halfelf.org/hacks/site-id-columns-multisite/

  3. flip_this
    Posted 4 years ago #

    Thanks! I did try that plugin in my quest to find the site ID, but when I uploaded it it threw up an error for line 22. The only change I made to the code is I saw that it had the <?php at the top of the text but it did not have the ?> at the bottom and I haven't had a chance yet to test and see if me adding ?> to the end is what caused the problem. I will test that and post back.

  4. flip_this
    Posted 4 years ago #

    And the follow up.

    I tried it without the closing ?> and I received this error:

    Parse error: syntax error, unexpected T_FUNCTION in /home/www/wp-content/mu-plugins/wordpress_site_id_columns.php on line 22

    I used notepad and saved it as a php. Is there a different editor that would be better for creating and editing php documents?

  5. *eyes the world today*

    I don't have a closing ?> on mine and it's fine, but y'know since it works with it, I'm just going to put that back on the page since you're the second person who had that problem. Stupid servers ;)

  6. flip_this
    Posted 4 years ago #

    Sorry I may have mis-typed, it doesn't work with the ?> and it doesn't work without it either. It throws up the same error either way.

    Is it possible that another plugin is calling the functions in the file?

  7. It's always possible another plugin is doing that :)

    You can always change the functions.

    Make all the site_id's and siteid_ into something else.

Topic Closed

This topic has been closed to new replies.

About this Topic