Support » Installing WordPress » WordPress MU

  • I’ve been trying to install WordPress MU and i keep getting the error “Error establishing a database connection”. I know i’ve entered the correct database name and username and password in the correct places in the wp-config.php file, but it still wont connect. I’ve read many posts about this error (for regular installs, anyways), and from what i’ve read, im doing everything right. So im guessing it has something to do with the MU version.
    I found a few things weird about this particular program, which im not sure hold any relevence, but i’ll mention them anyways. The wp-config.php file was origionally located in the blog/wp-inst/ directory. I edited it there, and when i tried to install, i got an error saying no such directory existed. It was looking in /blog/wp-inst/wp-blogs/wp-inst/wp-config.php, so i had to manually create that directory, then move the file there. Seems odd..
    Also, i’ve noticed some htaccess.dist files. I’ve never seen these before, so im not sure what to do with them.
    Anyways, i know i edited the wp-config.php file correctly, and that the database and user are set up correctly, so im at a loss. I also know theres nothing wrong with my server, because i have another wordpress instalation working fine. (a standard installation).
    If anybody has any ideas, please let me know. I’ve been at this for hours 🙁

Viewing 7 replies - 1 through 7 (of 7 total)
  • Update; I’ve installed it (kind of..)
    I can access the user menu, but when i try to “view site” i get a page full of the following errors;
    Warning: Smarty error: problem writing temporary file ‘/1054ec3fd01168bdf6c8f2cdc6ca56b1/%%200/%%2001463753/418212ab6ddea’ in /home/cynikals/public_html/blog/wp-inst/Smarty.class.php on line 1042
    Warning: Smarty error: problem writing temporary file ‘/%%200/%%2001463753/418212ab68fc9’ in /home/cynikals/public_html/blog/wp-inst/Smarty.class.php on line 1042
    Warning: touch(): open_basedir restriction in effect. File(/%%200/%%2001463753/index.html.php) is not within the allowed path(s): (/home/cynikals:/usr/lib/php:/usr/local/lib/php:/tmp) in /home/cynikals/public_html/blog/wp-inst/Smarty.class.php on line 1575
    And so on..
    Anyone know whats wrong?

    Odd… I had it installed without a hitch in v0.1. But then, it is a very early release and so much depends on your server (most notably support for Apache SymLinks, that a number of things can go wrong.
    I’d suggest that you try re-installing from scratch after empting your database (provided you had no important entries in it!), go download the latest nightly of WP-mu, simply upload the unzipped files in the desired location, leave config.php alone and try creating it through the “web interface”. that worked for me, anyway.
    So, if you installed it in and have a folder wp-inst inside that, point your browser to and *not* to I think the function of the htaccess.dist files is then to create the appropriate .htaccess files (and others?) while your page first loads, but I’m really shaky in this area. Anyone knows better? Donncha?

    Sorry, wrong login… That was me

    I figured out the htaccess.dist files are there to replace the current .htaccess files. At one point you will have to change the permissions of the .htaccess file, and you wont be able to. The only way to do that is to rename the htaccess.dist file to .htaccess with the proper permissions.
    Did you have to edit the smarty.class.php file at all?

    I tried the latest version from your link, and it did seem to go more smoothly, but i now get an “internal server error” when trying to “view site”.
    It seems to be looking for /blog/main directory where none exists.

    cynikalsam – did you check the error log? Did anything show up there as an error?
    What are the perms on the “blog” directory?

    I just fixed it. I modified Smarty.class.php, setting $use_sub_dirs to false.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘WordPress MU’ is closed to new replies.