Support » Plugin: Appointment Bookings for Zoom GoogleMeet and more - Wappointment » WordPress MU Support | Setup Does Nothing

  • Resolved discere

    (@thistlebean)


    Hello,

    When clicking “Setup” nothing happens. This is for WP MU setup.

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Contributor Ben

    (@benheu)

    Hello thistlebean,

    I answer here too, even though we have an on-going conversation by email already.

    So the reason why the setup doesn’t work is linked to your permalinks settings.
    Basically your nginx server is not properly configured to accept pretty permalinks. But your permalinks settings is “ON” for pretty links.

    Therefore our plugin won’t work, but also most of your URLs will be broken, and most plugins will not work either.

    So the best advice I can give you is to :

    • either switch your permalink settings to Plain in Settings > Permalinks
    • Or configure your nginx server to work with permalinks, you can read about it here

    Now as we don’t want to create a frustrating experience while you setup our plugin, we’ve created an update to catch that scenario, and send you a notice and a way to by-pass that issue.

    That patch will be released in the next version, maybe next week, maybe later, this said you can download the patched version already from our website at wappointment[dot]com/uploads/wappointment.zip

    Here is how you should proceed to install that zip:

    1. From your WordPress’ backend, go to Plugins
    2. Deactivate Wappointment and delete it
    3. then click Add New at the top of the screen
    4. Then click Upload Plugin at the top of the screen
    5. Select the file downloaded above and upload it
    6. Once you’re done, you can proceed with Wappointment’s setup
    7. A warning should appear explaining the issue about permalink, but you can proceed with the installation anyway

    Hope that helps!

    Cheers,
    Ben

    • This reply was modified 1 year ago by Ben.
    • This reply was modified 1 year ago by Ben.
    Thread Starter discere

    (@thistlebean)

    Thanks for the detailed reply!

    The Nginx modification worked by adding the line:
    try_files $uri $uri/ /index.php?$args;

    To my sites config file.

    Plugin Contributor Ben

    (@benheu)

    Great news!

    Should we mark this topic as resolved then?
    Or have you faced more issues installing Wappointment?

    Let me know!

    Plugin Contributor Ben

    (@benheu)

    Closing this topic

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘WordPress MU Support | Setup Does Nothing’ is closed to new replies.