Support » Networking WordPress » WordPress MU Domain Mapping, cannot change settings

  • Resolved kleja

    (@kleja)


    I’m setting up a some new WordPress 3.3 servers (Upgrade and fresh installs) all are multi-site enabled
    I’m using the WordPress MU Domain Mapping 0.5.4.1 plugin and noticed in the “Domain Options” when I change any of the settings and apply them the settings revert back. I’m apparently unable to change them from the defaults, or the pre-upgrade values.

    Am I missing something or is this a bug with either WP3.3 or WPMU Domain Mapping?

Viewing 15 replies - 1 through 15 (of 17 total)
  • i am facing same issue on wp3.3 with domain mapping plugin for a fresh install of network.

    I get the same problem.

    I try to turn off 1) Remote Login
    and switch on 2) Permanent redirect (better for your blogger’s pagerank)

    But when saving, they revert back to (1) on and (2) off

    Andrea Rennick

    (@andrea_r)

    Customer Care at Copyblogger Media and Studiopress

    3.3 bug with the plugin, yes we are aware of it.

    Ron Rennick

    (@wpmuguru)

    MultiSite Guru

    Try the development version about 1/2 hour after this post: http://wordpress.org/extend/plugins/wordpress-mu-domain-mapping/download/

    Wonderful, I’d be delighted.

    It will probably be a couple of hours before I get home to try it out but I will let you know the results right away.

    Thank you much for your efforts.

    ~K

    Perfect its working in development version.
    Requires a prompt of “settings saved”

    The development version seems to be working. Hooray!
    However, I have not checked much further than trying to change the settings. I have 2 more servers with the same issue that I will be testing it with more rigorously tomorrow.

    This was the only issue holding me back on a fairly ambitious project.

    Once again, Thank you for your efforts.

    Ken Leja

    HI everyone,

    After installing the development version the checkboxed options do stay updated when I hit save, however I tried to change the IP address and it does not update after saving. (Reverts to the original IP)

    Any ideas ?

    I get a similar problem, IP changes & additions are not taking, however all I get after changing and saving the Server IP Address is a blank page that has the text “Are you sure you want to do this?” with no prompts, buttons or anything else on it.

    I think I fixed the address issue… Would be my first WP Patch ever…
    I changed lines 297-298 as followed based on the changes in the last dev releases. The IP address field now seems to accept changes

    I commented out the existing line and updated it to match the previous changes.

    domain_mapping.php: Lines 297-298

    /* KSL 12/17/11 add_site_option( ‘dm_ipaddress’, $_POST[ ‘ipaddress’ ] ); */
    update_site_option( ‘dm_ipaddress’, $_POST[ ‘ipaddress’ ] );

    /* KSL	12/17/11	add_site_option( 'dm_ipaddress', $_POST[ 'ipaddress' ] ); */
    				update_site_option( 'dm_ipaddress', $_POST[ 'ipaddress' ] );
    Army

    (@wavesinair)

    I’m using wordpress 3.3 and the twenty eleven theme for testing.

    Mapping is working but changing the settings still does not work.

    1) Checking ‘remote login’ will not save.
    2) Additionally, when mapping is on, the wordpress admin bar at the top of the screen disappears. When I toggle mapping off, it comes back.

    I’ve tried multiple versions of this plugin, including the development version but these to 2 issues persist.

    Any ideas?

    Is this going to be resolved soon for WP 3.3?

    Moderator Ipstenu (Mika Epstein)

    (@ipstenu)

    Lead Plugin Wrangler

    Yes, the plugin devs know and are working on it.

    Anything planed for a new release?
    Please solve the problem and/or give us a workaround.

Viewing 15 replies - 1 through 15 (of 17 total)
  • The topic ‘WordPress MU Domain Mapping, cannot change settings’ is closed to new replies.