Support » Fixing WordPress » WordPress MU 2.6.5 RSS Feed down

  • Resolved rengel

    (@rengel)


    I’ve installed WordPress MU 2.6.5. on my http://ralfengel.com domain.
    I’m using it with subdomains – not virtual host wildcards but – CName setup on server config.
    On the main domain feeds work fine. On the first subdomain http://wordpress.ralfengel.com feeds work fine.
    Today I added a new subdomain at http://spirituality.ralfengel.com and as before tried to use the handy feedwordpress plugin to keep the main blog updated, which worked with the first subdomain, but, on this new subdomain it doesn’t work. I get this error message:
    Error: I couldn’t find any feeds at spirituality.ralfengel.com [HTTP request error: Invalid protocol “”\n]. Try another URL

    When I click on the feed url of the subdomain blog I get this message:
    This page contains the following errors:

    error on line 3 at column 6: XML declaration allowed only at the start of the document
    Below is a rendering of the page up to the first error.

    But, there is nothing else below…

    I’ve used <?php bloginfo(‘rss2_url’); ?> (RSS 2.0 format)
    <?php bloginfo(‘rss_url’); ?> (RSS 0.92 format)
    <?php bloginfo(‘rdf_url’); ?> (RDF/RSS 1.0 format)
    <?php bloginfo(‘atom_url’); ?> (Atom format) to get my feed info shown. It shows as:
    http://spirituality.ralfengel.com/feed (RSS 2.0 format) http://spirituality.ralfengel.com/feed/rss (RSS 0.92 format) http://spirituality.ralfengel.com/feed/rdf (RDF/RSS 1.0 format) http://spirituality.ralfengel.com/feed/atom (Atom format), tried them but neither works.
    Weird is that on my first subdomain everything went fine.
    I’m greatful for any help on this issue

Viewing 3 replies - 1 through 3 (of 3 total)
  • Googled a lot for this issue and found “Fix rss feed” plugin at Fuk Loi’s site.
    Comments on his thread confirm success with it, but I didn’t have any.
    As far as I got what he is doing:
    Going through all files on server and looking for empty spaces, at the beginning or the end of the file (I believe around the <?php command) eliminating those and saving the file.
    Logic that it didn’t work for me, since my main site and my first subdomain do work perfectly!!
    Still need help on this

    I’ve gone into the MySQL management page on the host, did a table cleanup:
    – Check Tables
    – Analyze Tables
    – Repair Tables
    – Optimize Tables
    After doing this the RSS feed worked perfectly.

    To read all the details on how I proceeded exactly please go to my WordPress MU RSS Feed doesn’t work post.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘WordPress MU 2.6.5 RSS Feed down’ is closed to new replies.