WordPress.org

Forums

WordPress memory and Fatal error issue (5 posts)

  1. gnrocks
    Member
    Posted 5 years ago #

    Hi there!

    Like many of you i have had an issue with WordPress exceeding the 32M limit and displaying this error :
    Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 491520 bytes) in /home/lesfeui/public_html/wp-includes/class-simplepie.php on line 4186

    I had many blank pages, not found pages. Finally i uninstalled all the plugins and it worked again.

    I have tried all the options to set the limit higher but my webhost is limited to 32M, so i'll contact him to higher it.

    Also, being very curious, i have installed the Memory Usage plugin and i compared localhost versus online.
    Localhost : Memory Usage: 6.13M/256M
    Online : Memory Usage: 31.13M/32M

    I was wondering why the same website, with exactly the same plugins, articles, posts, images, etc would use more memory online than locally ?

    Another question :
    I noticed that when i keep my .htaccess file, i have my permalinks but cannot access wp-admin and when i delete its content, i lose the permalinks but have access to wp-admin !
    Has anybody an idea on how to fix it ?

    Here is the content of my .htaccess :

    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    Any information would be very appreciated!
    Thanks a lot!

  2. Mark Ratledge
    Forum Moderator
    Posted 5 years ago #

    If you have tried all memory options, ask your host. They must have hard limits on RAM usage and you're stuck with them. WordPress › PHP / MySQL Web Hosting

    Lack of permalinks also points to a problematic host.

  3. gnrocks
    Member
    Posted 5 years ago #

    I finally had an answer from my webhost.

    1) create a php.ini that will contain following :

    <?php
    memory_limit = 64M
    ?>

    2) upload it to the public_html folder

    3) open the .htaccess file located in the public_html folder and add the following :
    suPHP_ConfigPath /home/domaine_username/public_html/

    Replace domain_username by your username for the cpanel.

    Your .htaccess may look like (the code between <ifmodule>...</ifmodule> can vary ), the important is to add the sentence before #END WordPress:

    # BEGIN WordPress
    
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    
    </IfModule>
    suPHP_ConfigPath /home/domaine_username/public_html/
    
    # END WordPress

    And that's it!
    Enjoy!

  4. Mark Ratledge
    Forum Moderator
    Posted 5 years ago #

    Who is your host? Those are very unusual settings and not to be used at other than that particular web host.

  5. gnrocks
    Member
    Posted 5 years ago #

    You are right, i should have mentionned my host !
    It is iWeb.

Topic Closed

This topic has been closed to new replies.

About this Topic