WordPress.org

Forums

WordPress, MediaTemple and "Black Zone" (1 post)

  1. Wiki Chaves
    Member
    Posted 4 years ago #

    Hi,

    I have a WP install on MediaTemple Dv server, and for some reason the blog reached the "Black Zone", something that I've never heard before.

    I've contacted the Technical support at MT and below is their answer

    Any idea of what can be done ?

    Best,

    -----

    Thank you for your response:

    As the (dv) Dedicated-Virtual Server is a self-managed solution, troubleshooting issues involving the run-time configuration of your (dv) as well as site content related issues are typically outside our scope of support (For more information, please see our "Statement of Support" web page, available at http://mediatemple.net/support/statement.php#dv). However, as a courtesy, I have agreed to shed some light on the issues you are experiencing.

    The parameters that you have been exceeding on your (dv) are directly related to the amount of RAM memory currently provisioned on your (dv) [Approx. 512M], The 'kmemsize' parameter, which appears to be the most commonly violated, corresponds to the maximum allowed size of the run-time kernel (included resources stacks) on your (dv).

    Whenever you receive "Black Zone" "QoS Alerts", especially with regards to 'kmemsize', and 'privvmpages', these will be related to the available size of unswappable memory, allocated by the operating system kernel, as well as the total memory allocation limit available at your class of service. The hard limit was reached and the resource allocation was refused, preventing additional processes from functioning correctly.

    Recovering from a "Black Zone" will typically require a restart.
    More information on possible causes and more permanent solutions to resolving this issue can be found in the following (mt) Wiki article, entitled "QoS Alerts: kmemsize" located at: http://wiki.mediatemple.net/w/QoS_Alerts:_kmemsize

    In general, however, as you are running a single site WordPress install, I would definitely suggest re-investigating your plug-ins. Your WordPress installation appears to be up-to-date. Further investigation of your MySQL installation revealed severe issues with regards to the amount of database activity on your (dv). Although your site does not appear to be "high traffic" the amount and scope of the database activity on your (dv) [Most likey, due to your choice of plugins] resulted in MySQL memory and disk thrashing, which definitely could affect and trip a "QoS Alert". As a once time courtesy, I have installed MySQL Tuner on your (dv), and adjusted your MySQL configuration (my.cnf) with it's recommendations, based on the amount of activity logged. I have restarted your (dv) in order for these changes to take effect. Your original 'my.cnf' has been retained as '/etc/my.cnf.mt'. I would suggest you read the following (mt) Wiki article, for more information on using MySQLTuner:

    DV:MySQLTuner
    http://wiki.mediatemple.net/w/DV:MySQLTuner

    The following is a list of changes made to your my.cnf:

    Increased the following settings:
    query-cache-size = 16M
    thread_cache_size=4
    table_cache=80M
    tmp_table_size=48M
    max_heap_table_size=48M
    query_cache_limit=4M
    set-variable = innodb_buffer_pool_size=4M

    I would recommend you rerun the MySQLTuner after approximately 48 hours to get a better idea of what your database activity is now, the increase in the table cache has produced a noticeable improvement.

    Finally, I would definitely suggest you implement some form of caching on your website, as it appears that there is not a lot of dynamic content generated. Our recommendation would be to use wp-cache2.

    I hope you find this information useful.

    If you have any further questions regarding your (mt) Media Temple services, please feel free to contact us at any time.

    Best Regards
    ....

Topic Closed

This topic has been closed to new replies.

About this Topic