WordPress kills RewriteRules (5 posts)

  1. Aleksandersen
    Posted 8 years ago #


    This .htaccess code in root should redirect from http://thewebdesignjournal.com/journal/2006/12/21/google-ends-web-20-era/ to http://thewebdesignjournal.com/2006/12/google-ends-web-20-era/

    But WordPress owerwrites the redirect so it does not work. How do I fix this?

    RewriteRule ^journal/([0-9+])/([0-9+])/([0-9+])/(.*)$ /$1/$2/$4 [R=301,NC]

  2. WPChina
    Posted 8 years ago #

    Right, I am having this problem too. Every few days I have to go back in and add my rewriterule again. Very annoying... anyone know a way around this?

  3. AskApache
    Posted 8 years ago #

    From a linux prompt:
    chmod 644 .htaccess

    If you have ftp client than change the files permissions by right-clicking.

    Or you can use a php/ajax shell console

  4. WPChina
    Posted 8 years ago #

    Thanks for the tip! Is 644 in any way a security problem or will it affect other things on the system?

  5. Samuel B
    Posted 8 years ago #

    No, that is the most secure setting. You should only change it to 666 to modify it.

Topic Closed

This topic has been closed to new replies.

About this Topic