WordPress just stopped working (7 posts)

  1. jasonroberson
    Posted 7 years ago #

    I decided to visit my site today and make a post and found this at the address waiting for me.

    404 Not found
    Warning: require_once(/etc/wordpress/config-www.iamroberson.com.php) [function.require-once]: failed to open stream: No such file or directory in /etc/wordpress/wp-config.php on line 16

    Fatal error: require_once() [function.require]: Failed opening required '/etc/wordpress/config-www.iamroberson.com.php' (include_path='.:/usr/share/php:/usr/share/pear') in /etc/wordpress/wp-config.php on line 16

    It was up and running yesterday and no server reboots, changes, upgrades or anything was made to it. (I am the only admin/user)

    I've never noticed a file used (like some) 'config-www.iamroberson.com.php' before but while searching for the resolution noticed others had it. The file is nowhere to be found on the server.

    I run multiple sites and they are all down with the same error. The way I run my multi-site installation is with WP-Hive. Again nothing was changed it just decided to die sometime over the last 24 hours. I can find nothing in the logs. Does this make sense to anyone?

    What information is needed to help diagnose this?


    - Jason

  2. tecnosh
    Posted 7 years ago #

    any update on sql or other server structure?

  3. jasonroberson
    Posted 7 years ago #

    Negative. Nothing was touched on the server or the blog itself from the time I last logged into it to check stats yesterday and today when I found it down.

  4. jasonroberson
    Posted 7 years ago #

    Has anyone seen this error before? It is not related to DNS like some I've seen. neither my domain.com or my http://www.domain.com are working.

    please help.

    I have spent hours trudging through google only to find that any problem that looked like mine was either a setup issue and the installation never worked or a dns issue. Niether of which worked for a solution for me.

  5. whooami
    Posted 7 years ago #

    /etc/wordpress/config-www.iamroberson.com.php <-- THAT file is not being found by your web server.

    Is it there?

  6. jasonroberson
    Posted 7 years ago #

    I understand what the system is looking for but I don't think that file ever existed. I certainly have never seen it in the past. I am under the impression that wp-hive handled it differently but maybe I am wrong. I certainly did not delete the file as the system died during a period where noone was around it.

    ill dig some more.

  7. jasonroberson
    Posted 7 years ago #

    Disregard. I have no idea what decided to die but I decided to rebuild and import the settings, posts, and data from the existing database. I've learned my lesson and did individual installs for each site. No more WPHive for me.

    Thanks for the attempts to help though.

    Happy posting!

Topic Closed

This topic has been closed to new replies.

About this Topic


No tags yet.