Support » Fixing WordPress » WordPress is loading old URL

  • brainms

    (@brainms)


    Hello everyone,

    I have the following problem:

    To redesign an older single page I created a new page with the name “new_abc”. The new page is now ready and should be used instead of the old page. For this reason I named the old page “old_abc” and changed the URL accordingly to not lose the old data.

    Now I want to call the new created page website.com/abc and I get a 404 error. Furthermore it shows me the url website.com/old_abc.

    Cookies and caches were deleted + cache plugin deactivated. Unfortunately it still does not work. How can I solve this problem.

    Glad about your solutions

    • This topic was modified 3 months ago by Jan Dembowski. Reason: Moved to Fixing WordPress, this is not an Everything else WordPress topic
Viewing 11 replies - 1 through 11 (of 11 total)
  • Moderator James Huff

    (@macmanx)

    Volunteer Moderator

    Did you also clear the caching plugin’s cache, or just deactivate the plugin?

    If you just deactivated the caching plugin, it may have left your site in a permanently cached state.

    Thread Starter brainms

    (@brainms)

    Thx for your message.

    Yes I have also cleared the cache before deactivating the plugin.

    Moderator James Huff

    (@macmanx)

    Volunteer Moderator

    Hm, does your hosting provider also offer a built-in cache? Who is your hosting provider?

    Thread Starter brainms

    (@brainms)

    So I called the provider and found out. They do not use a built-in cache.

    I also tried to use the Plugin “Better Search Replace” to change the urls but this does also not work

    Moderator James Huff

    (@macmanx)

    Volunteer Moderator

    Can you share the URL of the pages with the problem here?

    Thread Starter brainms

    (@brainms)

    Short update!

    As soon as I change the type to “Simple” under >> Settings >> Permalink, everything works again.

    If I change the permalink back to post name (which it should be) the problem exists again.

    I once gave the contact page a different permalink /contact-3 and then changed it back to /contact. Now it keeps redirecting from /contact -> /contact_old -> /contact-3 -> /contact -> /contact_old -> /contact-3 etc until the browser gives me an error because of the redirects.

    Moderator James Huff

    (@macmanx)

    Volunteer Moderator

    What’s the content of your .htaccess file?

    Thread Starter brainms

    (@brainms)

    So I have finally been able to identify the problem. It was the Yoast SEO plugin.

    I have not yet been able to find or clear the cache of the plugin. But I have deactivated the plugin for the time being to be able to continue working.

    Thank you very much James 🙂

    Moderator James Huff

    (@macmanx)

    Volunteer Moderator

    Ok, I recommend reporting the issue at https://wordpress.org/support/plugin/wordpress-seo/ so the plugin’s developers and support community can help you with this.

    Thread Starter brainms

    (@brainms)

    How can i report this issue there?

    Moderator Steve Stern (sterndata)

    (@sterndata)

    Forum Moderator & Support Team Volunteer

    Click that link. Scroll down to the bottom of the page. Bob’s your uncle (whatever that really means 🙂 )

Viewing 11 replies - 1 through 11 (of 11 total)
  • You must be logged in to reply to this topic.