WordPress.org

Forums

[resolved] WordPress Interface Not Viewing Properly (4 posts)

  1. abriel_s
    Member
    Posted 2 years ago #

    The laptop I was working on recently crashed. But, I managed to get everything on it backed up, including my recent WordPress project off of my local server (I use MAMP).

    I uploaded my SQL database and copied the WordPress website folder into my local server. The WordPress login interface looks normal, but after you get the login, it looks like this screenshot: http://abrielshipley.com/wp-issue.png

    Is there something I missed when transferring my WordPress project from my old local server to the new one?

    Any suggestions is greatly appreciated! :)

  2. Brandon Kraft
    Happiness Engineer
    Posted 2 years ago #

    Off the top of my head, it looks like the CSS may not be loading.

    Some ideas:
    1. For grins, empty the cache for your browser to make sure there's not something up there.
    2. Visit the update area of the wp-admin (wp-admin/update-core.php) and reinstall the latest version. Maybe something didn't copy over quite right.

  3. abriel_s
    Member
    Posted 2 years ago #

    Thanks for the advice!

    I actually asked this on WordPress Stackexchange as well, and here's the results of what happened: link

    Basically, I had to insert PHP to define the site URLs in the wp-config.php file.
    define('WP_HOME','http://example.com');
    define('WP_SITEURL','http://example.com');

  4. Brandon Kraft
    Happiness Engineer
    Posted 2 years ago #

    That'll do it too!

    With a localhost->localhost transition, I assumed the URL (http://localhost/foobar) would have been the same... but assumptions often are the mother of screwups, eh?

    Glad you're back up.

Topic Closed

This topic has been closed to new replies.

About this Topic