Support » Installing WordPress » wordpress “install.php” after config brings blank page/404

  • Resolved shadedecho


    I have unpacked the 2.5.1 codebase into a clean docroot for one of my domains. I made sure all the files permissions were liberal and appropriate. I made sure a blank DB was setup and credentials were correct. When I first go to my domain, it displays a message about needing a config file.

    So, I copied the sample config file to wp-config.php. Then it says my DB settings aren’t correct. So I set them correctly in that file.

    Then, I try to go to wp-admin/install.php, and it displays a blank page in Firefox and a standard “couldn’t find the page” error in IE.

    I get no errors or even an access attempt in my apache logs for this failed page.

    I have tried:
    1. turning on E_ALL error reporting.
    2. turning on WP_DEBUG
    3. upping the PHP.ini memory limit to 32MB (why the heck does WP need that much anyway!?)
    4. checking for permissions problems and deleting any stray .htaccess files.
    5. placing die() trace statements along the path inside wp-config.php and install.php… the death of the parse somehow seems to be inside of wp-settings.php, but that file is huge and complicated and I haven’t been able to spend the time to put trace statements throughout it to figure it out.

    I’ve been banging my head against this for some time now. I just want a simple free blog to post some open-source code examples out there! How hard can this be!

Viewing 1 replies (of 1 total)
  • solved it. was this line in my php.ini:

    zend.ze1_compatibility_mode = On

    I turned it off, restarted apache, and install comes up just fine (for now).

Viewing 1 replies (of 1 total)
  • The topic ‘wordpress “install.php” after config brings blank page/404’ is closed to new replies.