WordPress.org

Support

Support » Plugins and Hacks » WordPress installation stuck in a loop

WordPress installation stuck in a loop

  • Hi guys,

    I have an issue that when I complete the setup and proceed to the login screen or the website homepage. It takes me back to the installation page.

    It seems the installation never completes. I have checked the plugin debug.txt file and it display the following message:

    Line 720: Function: extract_variables, Message: The query is too big to parse properly.

    I have checked the pdo engine file and it seems to point to something about a “pcre limit”.

    My current “pcre” limits are:

    pcre.backtrack_limit 1000000000 1000000000
    pcre.recursion_limit 1000000000 1000000000

    Not too sure if I am looking at the right file and how to fix this issue. Any suggestions?

    https://wordpress.org/plugins/sqlite-integration/

Viewing 3 replies - 1 through 3 (of 3 total)
  • So I managed to get a more precise error message to display after the usual “Success” page. Which is the following:

    Warning: Invalid argument supplied for foreach() in /usr/www/users/jagabrveye/dev/wordpress/wp-content/plugins/sqlite-integration/query.class.php on line 409 Warning: Invalid argument supplied for foreach() in /usr/www/users/jagabrveye/dev/wordpress/wp-content/plugins/sqlite-integration/query.class.php on line 428 Warning: Invalid argument supplied for foreach() in /usr/www/users/jagabrveye/dev/wordpress/wp-content/plugins/sqlite-integration/query.class.php on line 409 Warning: Invalid argument supplied for foreach() in /usr/www/users/jagabrveye/dev/wordpress/wp-content/plugins/sqlite-integration/query.class.php on line 428 Warning: Invalid argument supplied for foreach() in /usr/www/users/jagabrveye/dev/wordpress/wp-content/plugins/sqlite-integration/query.class.php on line 409 Warning: Invalid argument supplied for foreach() in /usr/www/users/jagabrveye/dev/wordpress/wp-content/plugins/sqlite-integration/query.class.php on line 428 Warning: Creating default object from empty value in /usr/www/users/jagabrveye/dev/wordpress/wp-includes/capabilities.php on line 655 Warning: Creating default object from empty value in /usr/www/users/jagabrveye/dev/wordpress/wp-includes/capabilities.php on line 655

    After I proceed from this page I am taken back to the WordPress Installation page where I have to re-enter the Site Title, User name, Password, etc.

    Plugin Author kjmtsh

    @kjmtsh

    Hi, jagabomb.

    Thank you for reporting. It makes the problem very clear and helps me a lot. I committed the fix to subversion repository. Will you try the developer version? Download pdoengine.class.php file and replace it.

    http://plugins.svn.wordpress.org/sqlite-integration/trunk/

    If user defined pcre.backtrack_limit value is big enough, the plugin will make use of it instead of default value * 10.

    I hope it helps.

    Thanks kjmtsh,
    I have replaced the pdoengine.class.php file and it worked.

    Thanks so much again.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘WordPress installation stuck in a loop’ is closed to new replies.