Support » Installing WordPress » wordpress in it’s own directory

Viewing 15 replies - 1 through 15 (of 18 total)
  • Look Here:

    Giving WordPress Its Own Directory « WordPress Codex



    gutiela, that’s the wrong answer: the correct one is – yes, create a folder called “blog” and upload all the WP files (and folders) there.

    Thank You. But where does that blog folder go? In the root, public_html, etc…? And when I unzip the files and I have them in a folder named wordpress, can I just remane that folder blog and upload the whole thing?

    1. Yes, under public_html (=root in other words)
    2. You can either rename the folder to “blog” on your machine and upload it like that; or create a folder “blog” on the server and upload the content of the wordpress folder.

    Moshu, thank you so much! I didn’t know public_html was the root, no wonder I had problems before. What is the directory called that’s higher than public_html, in other words, the highest directory with the numbers: example-

    Don’t bother about that. The “root” for your website > where you should upload ALL your files (WP or otherwise) is always the public_html.
    On other servers you also find names like:

    Ok, hopefully my last question. I do have a www folder as well as the public_html. I noticed that when I put in two html files in public_html that a copy also showed up in the www folder. Could you tell me the difference between those, or direct me to a resource for more info? I can’t thank you enough for your time!

    I have the same setup on one of the servers I use. Never was able to figure out what the difference is – honestly. Just stopped thinking about it 🙂
    When working through FTP I always use the public_html to upload files, scripts and folders… and it works.


    moshu is right, simply disregard the WWW folder. Quite a few host setups figure that one, and it’s got to do with how they set up their server security and backup policies AFAIK.

    Ok, I installed wordpress to be shown on my website as . It is giving me an error thats to long to explain when I try and view the blog. What do you guys see? If you see the error, do you know what the problem is?

    I installed wordpress to be shown on my website as

    I bet you put some “fantasy” URIs in the two URI values in admin > Options > General. They have to be real.
    Where is the physical location of the WP install?
    What did you do to make WP “to be shown” at the address above?

    Both of my URI’s are exactly . The wordpress files are in the public_html folder, in a folder labeled “philosophy” . I’m not sure what you mean about the “to be shown” question. The site did work before though. I think its when I tried to change the URIs that it stopped working. I do have: /philosophy/wp-blog-header.php in the index.php.

    If the WP files are installed in the /philosophy/ folder and the (short and sweet) index is in the same directory – you should NOT touch it.
    I mean you do not need to modify the path to the wp-blog-header.

    However, if you placed the short and sweet index into your root directory, then you have to modify the path AND modify the blog URI in the Options.
    What URIs did you change?

    The index.php is in the philosophy folder. The file reads, <?php
    /* Short and sweet */
    define(‘WP_USE_THEMES’, true);
    I don’t remember which URI I changed first, I think I did both at one point. There are only two URIs, right? I was trying to follow a tutorial on how to get wordpress in it’s own directory. But I think thats what messed me up. I just don’t want it to be the home page. I want people to get to it as it were just another page in the site.

    Yes, if you don’t read carefully mistakes happen.
    As I stated in my very first post here – that tutorial was NOT valid for your question. If you still followed it… I can’t help.

    This is the WRONG line: if everything is in the same directory you do NOT alter the path! Leave it as it originally was:

Viewing 15 replies - 1 through 15 (of 18 total)
  • The topic ‘wordpress in it’s own directory’ is closed to new replies.