Support » Plugin: WordPress Importer » "WordPress Importer" Pluggin doesn't import

  • I have tried uninstalling and reinstalling and attempting to import in three browsers: Chrome, Firefox, and Safari on mac os 10.6.6

    The import allows me to select the .xml file that I wish to import to my new server. However, when I click “upload file and import” my local wordpress installation goes to a new page. The main body section of the new page has nothing with a heading saying “Import WordPress”. If I wait it does nothing. If I check to see if anything has been imported, it has done nothing.

    Hoping this can get fixed soon… I am planning on going live with the new site soon.. and want all of my old blogs available on the new site.. hoping I don’t have to manually recreate them with Copy + Paste.

Viewing 9 replies - 1 through 9 (of 9 total)
  • —-

    WORTHY OF NOTE: Upon further and closer examination, the .xml file that I wished to import was placed in the “Media” section of the dashboard. It wont allow me to attach it the import xml file to a post either.

    Not sure if this bit of info might help or not. But, just in case it does.

    Also, I am using ver. 3.1 of wordpress on a linux server.

    Plugin Author Jon Cave


    How large is the import file? It sounds like you might be hitting a memory limit or execution time limit.

    As it appears in the Media section it sounds as if it uploads correctly but then fails to parse properly before displaying the author mapping/creation form. If you enable WP_DEBUG and display errors for PHP do you see any warning messages?

    I’m having the same problem as above. How do I enable WP_DEBUG to see what might be wrong?

    (I exported my blog from and re-imported it again with no trouble. It just doesn’t want to import to my own hosted wordpress.)

    Plugin Author Jon Cave


    Read this set of instructions.

    I’m almost certain that this will be a memory limit error. WordPress does try to set a really high memory_limit in the admin section (256MB). But I guess you’ll have to try increasing the memory_limit setting in php.ini if you want to import this file.

    Could you tell me how large your input file is in (kilo|mega)bytes?

    Thanks – I’ll have a look.
    The file is only 962KB.

    OK, did all that. I now see the following at the top of the page, but it happens on all pages, not just the import page:

    Notice: register_sidebar_widget is deprecated since version 2.8! Use wp_register_sidebar_widget() instead. in /homepages/23/d95992400/htdocs/wp-includes/functions.php on line 3303

    Notice: register_widget_control is deprecated since version 2.8! Use wp_register_widget_control() instead. in /homepages/23/d95992400/htdocs/wp-includes/functions.php on line 3303

    Notice: has_cap was called with an argument that is deprecated since version 2.0! Usage of user levels by plugins and themes is deprecated. Use roles and capabilities instead. in /homepages/23/d95992400/htdocs/wp-includes/functions.php on line 3387

    Notice: has_cap was called with an argument that is deprecated since version 2.0! Usage of user levels by plugins and themes is deprecated. Use roles and capabilities instead. in /homepages/23/d95992400/htdocs/wp-includes/functions.php on line 3387

    The file is also converted to a text file:


    Plugin Author Jon Cave


    That’s output caused by a different plugin using old functions and arguments.

    As I said the symptoms sound exactly like you’re reaching the memory_limit or max_execution_time. You’ll have to talk to your host or look up specific instructions on their website for information on how to temporarily increase these values.

    You might also try reading through this codex page I only just discovered about importing large files. I think you only need to be concerned with the first two bullet points there as the file is small enough to be uploading properly, you’re just running into problems after that.

    I had the same problems (webhost being, I’m not surprised…) – I had to add the following two lines to my .htaccess file to force the use of php5. No idea why this was necessary but it fixed this problem entirely for me:

    AddType x-mapp-php5 .php
    AddHandler x-mapp-php5 .php

    Hope this may help you.

    Plugin Author Jon Cave


    verinox, thanks for sharing your exerience. I’ve never had any problems with PHP 4 and the importer myself. If possible could you try something out for me?

    It would require you to temporarily switch back to PHP 4 and add some code to your theme’s functions.php or an active plugin. If you’re able to and have the time could you add:

    function dump_xml_extensions() {
    	echo '<pre>';
    	var_dump( extension_loaded( 'simplexml' ) );
    	var_dump( extension_loaded( 'xml' ) );
    	echo '</pre>';
    add_action( 'admin_init', 'dump_xml_extensions' );

    This will dump two bits of information to the top of the admin panel. Once done remove the code and switch back to PHP 5 (much better than version 4) and report the results here.


Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘"WordPress Importer" Pluggin doesn't import’ is closed to new replies.