Support » Networking WordPress » wordpress-importer ignoring multisite settings

  • Resolved brocku

    (@brocku)


    I have a subdirectory multisite install with 16 blogs, and most of them are new, but I want to import content from our old WordPress 2 site into one of the WP3 blogs. I’ve exported a WXR from the old site and I’m using the wordpress-importer plugin to import the content into the new blog.

    The problem I have is that all the content gets imported into the root blog, when I’m doing it from the wp-admin section of a different blog.

    My WordPress install is in /blogs/ on my server, and I have a bunch of other blogs underneath that URL (e.g. /blogs/student12). I do the import at /blogs/student12/wp-admin/admin.php?import=wordpress and it reads and populates the content, but all that content ends up in the root blog instead of student12’s blog.

    Is there a way to force the importer to use the database tables corresponding to a specific blog?

Viewing 3 replies - 1 through 3 (of 3 total)
  • That shouldn’t be happening.

    Are you on WordPress 3.0 or 3.0.1? Also, are you running any plugins?

    Andrea Rennick

    (@andrea_r)

    Customer Care at Copyblogger Media and Studiopress

    Then something’s wrong somewhere, as it should import into the blog you are on.

    I chose the wrong WP version when I created this topic, it’s actually 3.0.1. Plugins are Akismet (deactivated) Hello Dolly (deactivated) and wordpress-importer (I’ve tried both network activating it and activating it on only this one blog).

    I’ve just been informed that it’s only happening on our test site, our live site importer is working fine, so I think it may be an environment issue. Sorry for the forum pollution!

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘wordpress-importer ignoring multisite settings’ is closed to new replies.