The Support Forums will be in read-only mode for a scheduled maintenance window on 01 September 2016 14:00 UTC - 20:00 UTC. More information.

WordPress ignores child theme templates (8 posts)

  1. SebastianWe
    Posted 5 years ago #

    Hi there,

    I've set up a child theme in WordPress 3.2.1 and editing the child style.css works fine, but any other template files I put in the child theme folder are ignored. I've read over a lot of articles and tutorials and I thought WP is supposed to look in the selected child theme folder first, but mine even ignores the child's comments.php when I delete the parent's comments.php so that only a blank page shows up. I've given the child theme the exact same directory structure as the parent. What am I missing? Thanks in advance!


  2. zeaks
    Posted 5 years ago #

    Can you link your style.css or site

  3. SebastianWe
    Posted 5 years ago #

  4. zeaks
    Posted 5 years ago #

    I thought you might of been missing the template tag, but you're not.

    I created a child theme, and added a comment to header.php and it notices the changes. Here's what I have at the top of the stylesheet.

    Theme Name: Inline Child Theme
    Theme URI: http://mysite.com
    Author: Kermit the Frog
    Author URI: http://myurl.com
    Description: Inlne child theme
    Version: 1.0
    License: GNU General Public License
    Tags: dark, light, white
    Template: inline
    @import url("../inline/style.css");

    I copied header.php over to the child theme folder, and added an echo, it showed up, then deleted header.php from the parent theme and it still works. http://twentyten.info

  5. SebastianWe
    Posted 5 years ago #

    Thanks. This is really weird. Where did you put the child header.php, in inline-child/lib/build/ or in the child's root? Not that it matters much at the moment as I've tried both ... :(

  6. zeaks
    Posted 5 years ago #

    It's in the root

  7. mcasdorph
    Posted 4 years ago #

    I had posted about this last month, I think it has to do with WP 3.2.1, I'm having the same issue...

  8. wimc
    Posted 4 years ago #

    Have you seen the solution here?

    This worked a treat for me...

Topic Closed

This topic has been closed to new replies.

About this Topic