Support » Plugin: WordPress HTTPS (SSL) » WordPress HTTPS conflict with W3 Total Cache

  • I’m having some trouble making WordPress HTTPS and W3 Total Cache play nice in regards to my cloudfront CDN.

    WordPress HTTPS 3.3.0 would add a :443 after your domain if you filled in 443 for the port number. This would make W3 Total Cache not replace domains with my cloudfront domain on SSL pages.

    The newest version of WordPress HTTPS does not add the :443 and thus W3TC keeps replacing my domains in HTTPS pages with the HTTP cloudfront domain.

    Note that W3TC is set to auto detect protocol (which does not seem to work with WordPress HTTPS) and is also set to not even use the CDN on pages with SSL (also does not seem to work with WordPress HTTPS).

    If anyone has any experience with making WordPress HTTPS, W3 Total Cache, and Amazon CloudFront all work together, I’d really appreciate it!


Viewing 3 replies - 1 through 3 (of 3 total)
  • I would also like to note that I’ve tried WordPress HTTPS domain mapping with => to not use the CDN on SSL pages but this does not seem to work.

    Plugin Author Mike Ems


    Well, 443 being on the URLs in my plugin was a bug. I removed them from URLs because users often feel the need to set the port to 443 unnecessarily. Most browsers will ignore 443 since its the default for HTTPS anyway.

    I’m not certain what you’re talking about with W3TC not working with WordPress HTTPS, but you have to remember how caching plugins work. The caching plugins will render a page and then save the output to a flat file. The next time the page is requested, the flat, cached file is served. This prevents WordPress or any plugins from executing when the page is loaded, so they can’t do anything. This is purely the nature of caching plugins.

    WordPress HTTPS domain mapping goes http://FROM => https://TO, so what you specified wouldn’t do anything. Also, domain mapping only works on external domains.

    If we can’t come up with any solution, I’ll just add a filter to the SSL Host that you can hook into and manually add the port. I really don’t want to allow users to specify 443.

    Thanks for your quick response!

    What I mean is that all of the cloudfront urls are loading in HTTP in the HTTPS page. For instance loads instead of on an HTTPS page. That is why I tried the domain mapping. I tried mapping back into my own domain and also from => to hopefully switch out the http:// to https:// but that did not work for me.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘WordPress HTTPS conflict with W3 Total Cache’ is closed to new replies.