WordPress.org

Support

Support » How-To and Troubleshooting » [Resolved] WordPress Gallery Thumbnails Give Blank Pages

[Resolved] WordPress Gallery Thumbnails Give Blank Pages

  • I’m having troubles with the new WordPress Gallery feature. As you can see on this example post, the thumbnails that I uploaded with the file uploader are working fine, but if you click on any of the thumbnails to view them full-size, you’re given a blank page. I’ve tried lots of ideas to try to figure out why it’s not working, but no dice. Any help would be much appreciated.

Viewing 3 replies - 1 through 3 (of 3 total)
  • designsimply

    @designsimply

    Member

    The image.php file in the garland theme is the culprit. It looks like you have upgraded WordPress, but your theme (or at least the part that displays full-size images for the gallery) has not been updated.

    Try renaming image.php to image.php.bak in your wp-content/themes/Garland-Wordpress-Theme folder.

    If you’d like to have more control over how the full-size image page looks, you can add an attachment.php file to your theme.

    See the WordPress documentation for Using Image and File Attachments for more information.

    Okay, that makes sense, except that the uploads aren’t working anymore; I keep getting an HTTP Error even though I know that all of the folders have been correctly set to CHMOD 777…

    Help!

    Never mind, apparently it was something wrong with PHP 5. Switching back to PHP 4 made it work again. *shrug*

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘[Resolved] WordPress Gallery Thumbnails Give Blank Pages’ is closed to new replies.