Support » Fixing WordPress » WordPress gallery stopped working

  • Hello, some time ago we had problems with SSL. We fixed the problem using an external plugin, but after a few weeks we noticed that the gallery with photos stopped working. When trying to view all the photos in the gallery, we get one unloaded miniature and endless download (Screenshot https://yadi.sk/i/_zbcTbxSmZSV6g). Also, if you try to upload a new photo, it is not displayed here and it is not on the server, but when you try to view it in a different mode, and not in thumbnail mode, you can notice that they are not determined by the site, while all the old ones continue to work correctly ( screenshot https://yadi.sk/i/JNs6cwmdxBLfAQ).

Viewing 7 replies - 1 through 7 (of 7 total)
  • Hi @c0mradeboy

    What external plugin did you use to fix the SSL issues?
    And what was the SSL issues anyways?

    Best regards
    Aris Kuckovic

    Thread Starter c0mradeboy

    (@c0mradeboy)

    Hi @kuckovic
    At first I tried to enter a rule for redirecting to https via htaccess, but there were some images on the site that did not want to be redirected to http, after that I tried installing the “Really Simple SSL” plugin, but the problem didn’t disappear. After that, I replaced all http with https in the database, but that didn’t help either. Then I went into the settings of the plugin “Elementor” and in changing the address of the site I asked to replace http with https. After that, everything worked out and for 2 weeks no one did anything on the site, and today when working with him this problem was discovered. There was also an option that perhaps this problem appeared after the WordPress update, but its rollback to an older version did not work.

    • This reply was modified 2 years, 1 month ago by c0mradeboy.
    • This reply was modified 2 years, 1 month ago by c0mradeboy.

    @c0mradeboy

    Sounds strange.
    Usually Really Simple SSL should do the trick just fine.
    Do you remember what errors you had with this plugin?
    Are you using any Media-plugin for your gallery?

    Best regards
    Aris

    Thread Starter c0mradeboy

    (@c0mradeboy)

    @kuckovic

    I assume that this error was created by “Elementor”. Because I noticed that notifications came to the working mail of the site that this plug-in gave a critical error and at the moment it does not start, updating it and reinstalling it does not lead to anything. Even if you disable all the plugins, the gallery does not work. No additional gallery management plugins were installed. Therefore, against this background, I conclude that the plugin “Elementor”, while making changes to the database, managed to break it. But plugins for checking the integrity of the database do not produce errors. At the Russian-language forum, I was advised to rename the “uploads” folder and try to create a new one, but this did not solve the problem, and everything remained in the gallery as before.

    • This reply was modified 2 years, 1 month ago by c0mradeboy.

    It remained the same, even though you renamed the uploads-folder?
    Have you tried contacting the Elementor devs in their support-forum?

    Thread Starter c0mradeboy

    (@c0mradeboy)

    @kuckovic

    Yes, deleting this folder has not given any result. I have run out of elemntor license, and on the free forum they have very little information to get. I came across the same problems in people who use elementor. but they, too, could not give an answer why it happened. 🙁

    Wow, sounds very strange, that they won’t look into this issue.
    I guess it’s a problem in general with Elementor then – if multiple users are facing the same issues.

    Sorry I couldn’t be to any help 🙁
    My best advice, contact the devs either through forum, but maybe also Twitter etc. – I’ve had some luck that way before.

    Best regards
    Aris

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘WordPress gallery stopped working’ is closed to new replies.