Support » Plugin: Simple Lightbox » WordPress Gallery missing images on mobile

  • Resolved ditryblog


    On the mobile view of the post linked below on my blog, there are quite a few images missing from the in-text galleries (2). I created the galleries through the built-in WordPress functionality. I’ve looked at those settings, though limited, as well as the settings on the individual images, but I can’t figure out why they’re not displaying on mobile. I am using Simple Lightbox for my site, but I would be confused if that was the issue because my understanding is that the plugin is used to open the images, not display them in posts, but maybe I’m wrong or maybe the two functionalities just aren’t compatible. Please advise!

    The page I need help with: [log in to see the link]

Viewing 1 replies (of 1 total)
  • Plugin Author Archetyped


    Hi, you are correct, SLB does not affect the output of content on the page, it only controls the display of the lightbox when a valid link is clicked.

    It appears that the page loads a different number of images in your galleries if it is loaded by a mobile device compared to when the page is loaded with a desktop browser. This is not standard WordPress behavior, so it is likely that it is being caused by a plugin or the active theme.

    Before anything, I would recommend deactivating all caching plugins to ensure that you are seeing the latest content. For example, it looks like you have a plugin called “Endurance Page Cache” caching the page.

    Once all caching is disabled/purged, you can follow this guide on troubleshooting plugin/theme conflicts to identify the plugin/theme causing this functionality. The guide is designed to find plugin/theme conflicts with SLB, but it works just as well to identify the plugin/theme responsible for a particular functionality.

    I’m closing this ticket as the issue does not appear to be directly related to SLB, but please let me know if you have any additional questions.

Viewing 1 replies (of 1 total)
  • You must be logged in to reply to this topic.