Support » Plugins » WordPress Gallery 2 Plugin

Viewing 15 replies - 1 through 15 (of 42 total)
  • very very nice! Glad to see you were able to make progress on integrating Gallery 2.

    This doesn’t seem to work very well with the kubrik default theme…

    Everything seems to be offset by a few milimeters…

    Any idea how to fix this? I had the same problem when I tried to integrate the theme myself!

    To see what is going on have a look at:
    http://www.1kemp.co.uk/wordpress/wp-gallery2.php

    But this is definatley a move in the right direction!!

    add in a <div=”content”> to shift it over as it’s being aligned with the border and not the content area.

    I’ll make the change in the wp-gallery2.php file tonight.
    Thanks.

    I tried putting it in but it didn’t work!?! It’s probably my very poor CSS skills though!!

    It adds in a <div=”content”> but this is immediatley follwed by a <div id=”gallery”> from the
    echo $g2data[‘bodyHtml’]; command…

    As a result nothing moves…

    Also it has added a black border around the bacground image…

    Any ideas what I am doing wrong…

    So how would people like this handled?

    There are some themes like WordPress Default 1.5 based on Kubrick that need the <div=”content”> wrapping the embedded gallery,
    There are others that don’t like WordPress Classic 1.5.

    In addition some themes include the sidebar in the header or footer, others don’t.

    So what would people like to see? An admin setting to turn on and off <div=”content”> wrapping? and setting to include the sidebar?

    Search the header file for the class=content tag?

    Or just have people manually edit the wp-gallery2.php and comment where it could go?

    Andy, try <div id=”content” class=”narrowcolumn”>
    Place it on line 53 after

    if ($wraptheme!=”No”) {
    get_header();

    So it should look like

    //Include WP Theme or basic html header
    if ($wraptheme!="No") {
    get_header();
    echo '<div id="content" class="narrowcolumn">';
    }else{
    echo "<html>n<head>";
    }

    Arnold,
    I tried what you suggested but it didn’t work… SoI played about with it and managed to get it working by putting the <div id=”content” class=”narrowcolumn”> in like this:

    echo ‘<div id=”content” class=”narrowcolumn”>’;
    echo $g2data[‘bodyHtml’]; //Display the gallery content
    echo ‘</div>’;

    I also had to add a </div> to get it to work…

    That said I am still getting some form of black border around the background that shouldn’t be there!

    Any ideas?

    Hi Andy,

    The Border is caused by the <div id=”page”> in the theme you’re using. Gallery has a style defined for that id.

    The two options I see are comment out the Gallery Header

    //Start Gallery Header
    echo $g2data['headHtml']; //Display the gallery header

    Or change the page to a different name and update the stylesheet to look for the new name.

    Sorry about not including the closing </div> it looked like you had added it to the page when you added the <div=”content”> as suggested by lawtai.

    I prefer including the div tag in the them included header, because if you turn off themes then you don’t need the encasing div tags.

    But placing it before the gallery header should be fine.

    Thanks Arnold! You have been a great help! I shall have a play with this today and let you know how I get on…

    By the way I would love to see an option page within the admin section to alter these settings. Keeps it all nice and neat!

    I guess my only issue is that for some reason when i log into gallery 2, it wont let me admnister anything…it gives me an error saying, i dont have permission, even though i’m logged in as admin and it says welcome, site administrator.. 🙁

    any ideas?

    Do you mean when you go back to the admin site?

    I am having a similiar problem when I go back to the regular gallery page, I can no longer log in… I have tracked this down to something to do with the cookies but short of deleting all my cookies (which I have done once!) I don’t seem to be able to login…

    Any ideas?

    I keep getting the error

    Warning: main(/home/lesliex/public_html//galleryembed.php): failed to open stream: No such file or directory in /home/lesliex/public_html/wp-content/plugins/wp-gallery2/g2embed.php on line 37

    Fatal error: main(): Failed opening required ‘/home/lesliex/public_html//galleryembed.php’ (include_path=’.:/usr/lib/php:/usr/local/lib/php’) in /home/lesliex/public_html/wp-content/plugins/wp-gallery2/g2embed.php on line 37

    Now whenever I login to the admin, it always shows the error on every page. It only stops when I delete the plugin.

    welp…there went THAT plugin…..:( nice try though.

Viewing 15 replies - 1 through 15 (of 42 total)
  • The topic ‘WordPress Gallery 2 Plugin’ is closed to new replies.