Support » Plugins » Hacks »      WordPress function for require/include ?

  • Resolved lieutenantdan

    (@lieutenantdan)


    I was wondering if anyone knows of a function to replace the require/include, because when I run the Developer plugin it gives me this message and I would love to solve it.

    INFO: theme_options.php The theme appears to use include or require. If these are being used to include separate sections of a template from independent files, then get_template_part() should be used instead.
    Line 370: require_once(TEMPLATEPATH . '/admin/validate.php');

    but I don’t think get_template_part() works with directories being as I get an error that my validating functions aren’t defined. Unless I have the get_template_part() code wrong, dunno?

    get_template_part( "admin/validate.php" );

Viewing 1 replies (of 1 total)
Viewing 1 replies (of 1 total)
  • The topic ‘     WordPress function for require/include ?’ is closed to new replies.