Support » Fixing WordPress » WordPress export gets me error 500

  • Trying to export wordpress from personal computer to hosting service when i am trying to export wordpress it gives me a 500 error “The server encountered an internal error and was unable to complete your request. Either the server is overloaded or there was an error in a CGI script. “
    I have four other wordpress blog that I exported without any glitch, this one is a bit bigger than the others and has some pictures (souldnt make a differance).

    How can I solve this?
    any other way I can export wordpress?

    Thanks for your help.

Viewing 5 replies - 1 through 5 (of 5 total)
  • I have the same thing. I upgraded my old blog to wp 2.2.2, tried Export but only got an internal server error 500.
    I’m using Firefox, but IE doesn’t do it either.

    Does anyone know what to do?
    Thanks!

    That’s becouse you (or the admin) have mod_security installed with apache. To resolve this problem you must disable it in apache config, restart apache, export, put it back on.
    If you don’t have root access on the server you have to ask the admin to do it otherwise you can’t export.
    At least this was my experience. Hope this help you.

    OK, that makes sense… I’ll try if that’s it.

    Thanks!

    I have this problem as well, but I never used to and I believe I’m the only admin so I don’t know how this could have changed. Could anyone provide more detailed instructions for modifying apache? I’m pretty novice and don’t want to screw anything up. Thanks!

    whallify

    (@whallify)

    I’m getting error 500 for export.php as well. However I have other blogs running same wordpress version (2.3.3) on the same exact server and I can export just fine.

    My apache access log shows:

    ip.address.removed.here - - [16/Jul/2008:11:36:57 -0400] "GET /blog/wp-admin/export.php HTTP/1.1" 200 6701 domain.tlc "http://domain.tlc/blog/wp-admin/edit.php" "Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 6.0; SLCC1; .NET CLR 2.0.50727; .NET CLR 3.0.04506; InfoPath.2; MS-RTC LM 8; Zune 2.5)" "-"
    ip.address.removed.here - - [16/Jul/2008:11:36:58 -0400] "GET /blog/wp-content/plugins/polls/polls-admin-js.php?ver=2.20 HTTP/1.1" 200 6845 domain.tlc "http://domain.tlc/blog/wp-admin/export.php" "Mozilla/4.0 (compatible; MSIE 7.0; Windows NT6.0; SLCC1; .NET CLR 2.0.50727; .NET CLR 3.0.04506; InfoPath.2; MS-RTC LM 8; Zune 2.5)" "-"
    ip.address.removed.here - - [16/Jul/2008:11:36:59 -0400] "GET /blog/index.php?ak_action=aktt_css_admin HTTP/1.1" 200 686 domain.tlc "http://domain.tlc/blog/wp-admin/export.php" "Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 6.0; SLCC1; .NET CLR 2.0.50727; .NET CLR 3.0.04506; InfoPath.2; MS-RTC LM 8; Zune 2.5)" "-"
    ip.address.removed.here - - [16/Jul/2008:11:36:59 -0400] "GET /blog/index.php?ak_action=aktt_js_admin HTTP/1.1" 200 717 domain.tlc "http://domain.tlc/blog/wp-admin/export.php" "Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 6.0; SLCC1; .NET CLR 2.0.50727; .NET CLR 3.0.04506; InfoPath.2; MS-RTC LM 8; Zune 2.5)" "-"
    ip.address.removed.here - - [16/Jul/2008:11:37:04 -0400] "GET /blog/wp-admin/export.php?author=all&submit=Download+Export+File+%C2%BB&download=true HTTP/1.1" 200 645 domain.tlc "http://domain.tlc/blog/wp-admin/export.php" "Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 6.0; SLCC1; .NET CLR 2.0.50727; .NET CLR 3.0.04506; InfoPath.2; MS-RTC LM 8; Zune 2.5)" "-

    and it’s the line with the author=all that gives the 500 error. I’ve tried restricting to one particular author and it still gives me the error.

    Anyone know what else I should try?

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘WordPress export gets me error 500’ is closed to new replies.