WordPress.org

Forums

WordPress error message Fatal error: Allowed memory size of 33554432 bytes ex... (7 posts)

  1. jaspn
    Member
    Posted 2 years ago #

    Hi,

    I am getting these error messages in in Incoming Links, Plugins and WordPress Blog boxes on the dashboard:

    Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 30720 bytes) in /home/itresour/public_html/wp-includes/SimplePie/Parser.php on line 114

    Usually it's due to a lack of PHP memory. However, I've allocated 128mb up form 32mb (as confirmed with a phpinfo.php file) but I'm still getting the messages. Is this issue unrelated to memory? Everything else in the website seems fine, but these messages indicate something is not right somewhere and it makes me feel a bit uneasy.

    Plugins I have installed are:

    • Collapse-O-Matic
    • Contact Form 7
    • Image Zoom
    • Multiple content blocks
    • Next Page, Not Next Post
    • Nivo Slider WordPress Plugin
    • Raw HTML Snippets
    • TinyMCE Advanced
    • WP Google Maps
    • WP Google Maps - Pro Add-on

    Any help or ideas would be appreciated.

  2. Try giving WP itself more memory in wp-config.php, and back the php.ini setting down to 32 megs. Using FTP, add the "define" line below in your wp-config.php file a few lines of white space below the opening <?php

    define('WP_MEMORY_LIMIT', '128M');

  3. jaspn
    Member
    Posted 2 years ago #

    Hi songdogtech,

    I forgot to mention in the above that I already added a define memory limit to the WP config file, which was

    define('WP_MEMORY_LIMIT', '64M');

    For some reason though, it never, ever seems to do anything, as...

    Allowed memory size of 33554432 bytes exhausted

    ...means I'm still limited to 32m. I'm at a loss.

  4. Try changing memory allocation in the main php.ini. If you're changing the account php.ini and nothing happens, you're limited by the web host, because the main server php.ini file isn't allowing account php.ini files to override it.

  5. jaspn
    Member
    Posted 2 years ago #

    Thanks for the suggestion songdogtech, but I had done this also. Using phpinfo.php, I can see that the memory limit is what I have set it to in a php.ini file: 128m. This leads me to think it's an issue with WordPress and not some external setting.

  6. jaspn
    Member
    Posted 2 years ago #

    After looking into things further, it appears the site is seriously not working as it should from an admin point of view. I am unable to create pages, modify settings, or do anything without this error popping up. Is there a debugging tool that can be used to pinpoint issues?

  7. Journey
    Member
    Posted 1 year ago #

    I am having the same, or similar, problem (it seems) as jaspn. My error message is : Fatal error: Allowed memory size of 41943040 bytes exhausted (tried to allocate 7173 bytes) in /home/journey/public_html/wp-includes/functions.php on line 336

    Have any resolutions been determined?

    Thank you.

Topic Closed

This topic has been closed to new replies.

About this Topic