Support » Plugins » WordPress Email Notification Plugin v2.3.0

  • The Word Press Email Notification Plugin has been updated to version 2.3.0.

    Updates to this version:

    • Added notification of future posts so that they only get sent at some point in time after they are published
    • Added an option to set default send option
    • Moved the admin panel under the “Manage” tab

    If you see anything that looks like a bug or the documentation needs corrected, please let me know via blog comment.

Viewing 15 replies - 1 through 15 (of 16 total)
  • I’m having trouble with your plugin. I followed the instructions that came with the plugin, and I added the extra line in the header. I also changed line 19 for line 22, and I subscribed a user to test the plugin.

    I encountered 2 problems:

    PROBLEM ONE: ERROR IN HEADER
    I have the following errors in the header of my page

    Warning: mysql_num_rows(): supplied argument is not a valid MySQL result resource in /home/xxxx/public_html/wp-content/plugins/wp-email-notification/email_notification_2.3.php on line 369
    Warning: mysql_fetch_assoc(): supplied argument is not a valid MySQL result resource in /home/xxxx/public_html/wp-content/plugins/wp-email-notification/email_notification_2.3.php on line 372

    Both of these errors dissappear if I take out the extra line in the header

    PROBLEM TWO: INCOMPLETE WRITE POST/PAGE
    When I try to create or edit an existing post/page I get an incomplete version of it. I don’t get to see anything below the Save/Post buttons. If I disable the plugin it then renders the page completely

    has anyone experienced this?

    yep. same problem here. 🙁

    Hi,
    I have the same problem, I don’t see the post page completely.
    I look inside the code and I don’t know where is the error

    Thanks

    everything seemd fine but confirm email is not being sent out. after several test subscriptions i went to check my subscribers list and it says this:
    “Could not successfully run query (SELECT * FROM wp_email_list) from DB: No Database Selected”

    i checked my config in maillist folder and settings are fine. please help.

    This is the oddest thing. I have several WP sites scattered over different web hosts.

    1. My blog (http://babygotblog.com) is hosted at DreamHost, and I installed this plugin and it performs FLAWLESSLY. No errors whatsoever, and test subscriptions went through without a hitch.

    2. Feeling quite lucky, I then dared to install the plugin at a WPMU site, http://petdiaries.net. (It’s hosted at SurpassHosting.com, a cPanel type account). It’s a bit tricky working with WPMU, somethings are the same and some things are different. When WPMU started throwing out Fatal errors, I decided the plugin wasn’t compatible with WPMU and scrapped it.

    3. I then moved on to my web design site (http://webjones.org). Thought for sure this would go without a hitch, as it’s hosted at Global Internet (cPanel type hosting). Noooo. I got the same errors I got with my WPMU site! I did nothing different whatsoever. So now I’m thinking, if I can solve this problem, there might still be hope for my WPMU site.

    Why is it working on one site and not the others?

    Here is the error webjones.org is throwing out:


    Warning: main(/maillist/wpemn_config.php): failed to open stream: No such file or directory in /home/webjones/public_html/wp-content/plugins/wp-email-notification/index.php on line 19
    Warning: main(/maillist/wpemn_config.php): failed to open stream: No such file or directory in /home/webjones/public_html/wp-content/plugins/wp-email-notification/index.php on line 19
    Warning: main(): Failed opening '/maillist/wpemn_config.php' for inclusion (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/webjones/public_html/wp-content/plugins/wp-email-notification/index.php on line 19
    Import Addresses :: Export Addresses :: Remove Addresses :: Email List Subscribers :: Update Settings
    Warning: mysql_connect(): Access denied for user 'webjones'@'localhost' (using password: NO) in /home/webjones/public_html/wp-content/plugins/wp-email-notification/index.php on line 44
    Warning: mysql_select_db(): supplied argument is not a valid MySQL-Link resource in /home/webjones/public_html/wp-content/plugins/wp-email-notification/index.php on line 45

    Update: Not all web hosts are alike, so it seems. I had to go in and edit the wp-content/plugins/email-notification/index.php file. The default is this:


    /* If maillist isn't located at your web root this will need to be changed */
    include ("$DOCUMENT_ROOT/maillist/wpemn_config.php");

    /* If your maillist directory is located in your wordpress directory, you can use this instead of line 19 */
    // include (ABSPATH."/maillist/wpemn_config.php");
    ?>

    Notice that the DOCUMENT_ROOT line is uncommented (operative) and the ABSPATH line is disabled. To get rid of my errors, I had to flip-flop them, like this:


    /* If maillist isn't located at your web root this will need to be changed */
    // include ("$DOCUMENT_ROOT/maillist/wpemn_config.php");

    /* If your maillist directory is located in your wordpress directory, you can use this instead of line 19 */
    include (ABSPATH."/maillist/wpemn_config.php");
    ?>

    Hope this helps someone else. I think this is a great plugin and am off to add it to my “Plugins Used” pages.

    So… is there a way to have the “thanks for subscribing page” within your theme or must it be on the blank page?

    Or rather… I’m sure there is a way… but is it something that could be relatively easily accomplished by someone who is willing to take some time to figure simple stuff out, but isn’t a coder by nature/profession?

    No point in trying something that’s going to be way beyond me anyway…

    Can you do anything about giving it a Sender ID, so it won’t be filtered as spam?

    I’m getting the same error as nuessly (the no database selected error)… i don’t have time to investigate (since I am travelling so much) so i unfortunately had to deactivate the plug in and take the subscribe form off of my index page 🙁

    i’ve installed the plugin, and I dont receive any errors. Confirmations emails are being sent out, and people are able to sign up. But when posting an entry no emails are sent out. what am I missing?

    cocababy541: are you just publishing the posts, or saving as drafts first then publishing. I’ve been trying it out and for me at least, if I save as draft first, then publish, it won’t send the email, and I can’t figure out why

    TheDude73

    (@thedude73)

    I am having the same problem with getting the notification when a post is published (not saved as draft, just directly published). Confirmation emails go out, and I can email the list directly, but no one is getting messages stating that there is a new post. Anyone figured this out?

    Dgold

    (@dgold)

    From the plugin’s Wishlist (upcoming plans), I see this

    To Do & Wishlist
    * Add digest option (send once a day or week)

    For me, I will be able to use this plugin when the digest option is implemented! Right now I cannot use it because I often see a typo, mis-spelling, or I decide to make Edits on my post after I have already pressed “Publish”! I do not want to email my users with a typo!

    TheDude73

    (@thedude73)

    I really wish I could email members just once with a new post. I guess although it seems to be a common problem (not getting email notifications after a post, but everything else functioning), no one has figured it out or cares to share their solutions.

    I am having a few minor issues with this plugin.

    Problem 1

    Back link is http:///mydomain.com not http://mydomain.com, where do I go to remove the extra /

    Problem 2

    The activation link being emailed out is missing the / between http://mydomain.com and maillist

    Im sure this is easily solved but I don’t want to make it any worse!

    Thanks in advance

    I have solved the problem above but;

    I have recently installed the latest WP and email notification, everything now works ok except that I am not receiving email notification! It appears that it may have something to do with times – nothing is being put in the fufure table though. The box that needs to have yes in it does. My WP Blog is set for UK time and the server is in the US somewhere. I have tried changing the code mentioned before but I am unable to find the exact code that needs to be changed. I have changed a similar piece of code and get an error message so have had to revert back.

    Thanks in advance

    (I posted this on the watershead email notification blog)

Viewing 15 replies - 1 through 15 (of 16 total)
  • The topic ‘WordPress Email Notification Plugin v2.3.0’ is closed to new replies.