Support » Fixing WordPress » WordPress Editor Lags – Delayed Responses to Keyboard Commands

  • Resolved wpwd2016

    (@mwarbinek)


    This was also mentioned in this post,

    https://wordpress.org/support/topic/resolved-very-slow-laggy-textvisual-editor/

    Since that other post was locked, no replies allowed, I created this post to give information on the “FireFox / WaterFox” and “Opera” browser.

    The problem of lagging or delayed response to keyboard commands as spacebar, backspace, typing letters, manual correction of text, etc.

    The cause of this issue is the incompatibility between WordPress and the native Spell Checkers included in browsers. This shows to be across the board, on all major browsers for Windows (Chrome – FireFox/WaterFox – Opera).

    • I disabled all plugins on my site, problem persisted.
    • I changed to a WordPress default theme with all plugins disabled, problem persisted.
    • I disabled all plugins/extensions in the browser, problem persisted.
    • I tested browser extensions/plugin spell checkers and the same issue occurs. Even with plugins that check grammar.
    • I tested WordPress Spell checker plugins, same problem.

    Cause
    A spell checker program is constantly monitoring the input and checks spelling/grammar during the input. This causes a delay in the WordPress editor. WordPress is not compatible with any Spell or Grammar Checker. All cause lag or delay in the WordPress Editor.

    Fix
    Disable any Spell / Grammar checker plugin/extensions for the browser or for WordPress.

    Disable the browser’s native spell checker (or plugins/extensions).

    Where to Find Browser Native Spell Checker?

    • FireFox-WaterFox: Top text menu (if not showing, press “Alt” keyboard key) > Tools > Options > Advanced > (under Browsing) Uncheck “Check your spelling as you type”. > Close Options Panel
    • Opera – Click “Menu” button Top left of browser > Settings > Browser (left panel) > under “Languages” (right panel) > click “Dictionaries” > unckeck “Enable Spell Checking” (bottom left of popup box) > click “Done” button.
    • Chrome – click the 3 vertical dots, right top of the browser > Settings > Settings Menu (Left Side) > Advanced > Languages > (under) Languages (right panel) > Spell Check > turn off “English (United States), or whatever language it says, and any other “on/off” slide button under this same Spell Check panel.

    Unfortunately, until WordPress fixes this, problem will persist. If you use spell checkers, a lag will persist.

    Sad but true, and this has occurred with the recent updates of WordPress, since I remember when this was not an issue in the past, but now it is.

    • This topic was modified 2 years, 10 months ago by wpwd2016. Reason: Marked resolved
Viewing 8 replies - 1 through 8 (of 8 total)
  • It’s also worth noting that some of the settings in Yoast can cause lag. For me the built-in browser spell checkers don’t cause a lag, but some of the settings in Yoast do.

    To turn them off go to Yoast Settings > General >

    Then disable readability analysis and keyword analysis. I think those two are the main culprits but it’s probably worth disabling any of the other features you don’t use.

    FireFox/WaterFox have been undated recently. Access to the spell check setting is different, here is where you find it,

    (Top text menu) > Tools > Options >Advanced (left side menu) > General (tab) > uncheck – “Check your spelling as you type”.

    Note: each time Firefox/Waterfox is updated, the spell check is reactivated by default.

    • This reply was modified 2 years, 7 months ago by wpwd2016. Reason: grammer correction
    • This reply was modified 2 years, 7 months ago by wpwd2016. Reason: Add info

    @wpspellcheck – I tried your plugin, does not work well, I removed it. FireFox has changed recently with their updates and things are going wrong, not working well, so that could be the reason.

    I noticed that having the Browser Inspector tools open in the tab which has the page preview can cause significant delays in the repsonsiveness of the WP Editor. Closing the Inspector is an immediate fix.
    It would be great if this could be addressed.

    In my case, Yoast plugin is the problem. When I turn Yoast off, the editor lag is gone.

    Yoast was the issue in my case too. As soon as I deactivate Yoast the issue disappears. I’ve reached out to Yoast Support for a fix.

    Unfortunately, this lag caused by the Yoast plugin is over a year old now and after all their updates they have not fixed it and even ignored my recent ticket/posts about it.

    As a result, I dumped Yoast. They failed to care about the important issue so I removed their plugin and installed All in One SEO, which causes No Lag.

    I believe it is all the background scripts working in the Yoast plugin to give convenient on the fly info. Nice idea, but as with anything it became bloated and a burden to WordPress. Yoast was trying to be too convenient to people and are instead creating more problems than it’s worth.

    • This reply was modified 1 year, 11 months ago by wpwd2016. Reason: spelling error fixed
    Sean

    (@seanpramsey)

    It was Yoast for me too. The “SEO analysis” and “Readability analysis” settings both needed to be turned off.

    It’s under General > Features tab. Here’s the URL for the settings: /wp-admin/admin.php?page=wpseo_dashboard#top#features

    I agree with wpwd2016. It’s a really useful plugin but this bug makes it too difficult to use.

    MacBook Pro 2012, Chrome

    • This reply was modified 1 year, 11 months ago by Sean.
Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘WordPress Editor Lags – Delayed Responses to Keyboard Commands’ is closed to new replies.