Support » Fixing WordPress » WordPress down after changing siteurl

  • Hi,

    I’m desperate for some help I had a fully functioning wordpress site without a domain, it was still using the server’s public ip, I transferred it to another server and had to change the site url because it was redirecting to the old server.

    I used the wp-cli to search and replace the old ip with the new one, there were three instances in the database. But the website still wasn’t working.

    So I defined the siteurl and home in the wp-config.php and it didn’t work, sometimes redirecting to the old site. I cleared my DNS cache and cookies, and openned thed site in incognito mode, just a blank screen.

    Turned on debugging mode, but I only get “There has been a critical error on this website.” and in there’s nothing in the debug log.

    Chcked out the apache access and error codes, nothing, disabled the themes and plugins, still nothing.

    Read that I should add SubstitueMaxLineLength 10m to the top of the .htaccess file, that gave me an apache error
    /var/www/html/.htaccess: Invalid command ‘RewiteOptions’, perhaps misspelled or defined by a module not included in the server configuration, referer: http://206.189.111.121/

    What else can I do?

    The page I need help with: [log in to see the link]

Viewing 4 replies - 1 through 4 (of 4 total)
  • Moderator t-p

    (@t-p)

    For single installs of WordPress, try changing URL directly in the database following this article: Changing the URL directly in the databas

    Backup: If you haven’t already done, always backup everything (including your database) before doing any actions, just in case something really goes wrong. You can never have enough backups! See https://wordpress.org/support/article/wordpress-backups/

    Thread Starter shalashtein

    (@shalashtein)

    @t-p I have changed the siteurl and home addresses but it’s still giving me “There has been a critical error on this website. Please check your site admin email inbox for instructions.” without any detailed errors in the logs to investigate

    Moderator t-p

    (@t-p)

    Try manually resetting your plugins (no Dashboard access required). If that resolves the issue, reactivate each one individually until you find the cause.

    If that does not resolve the issue, access your server via SFTP or FTP, or a file manager in your hosting account’s control panel, navigate to /wp-content/themes/ and rename the directory of your currently active theme. This will force the default theme to activate and hopefully rule-out a theme-specific issue (theme functions can interfere like plugins).

    Thread Starter shalashtein

    (@shalashtein)

    @t-p Thanks for the reply, but if I already tried disabling the themes and plugins via ssh, I tried all the common fixes

Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.