Support » Fixing WordPress » WordPress doesn’t do IPv6?

  • Hi all,

    I have the distict impression that WordPress has serious problems on systems that are fully IPv6 enabled.

    Tonight I installed WordPress fresh and clean on my Raspberry Pi with Debian Stretch and Apache 2.4. Ports 80 and 443 are open.

    When I e.g. go to wp-admin/plugin-install.php I get the “An unexpected error occurred. Something may be wrong with WordPress.org or this server’s configuration. …” Debug says the error occurs in wp-admin/includes/plugin-install.php on line 168. The access.log says it happens when my site is accessed via IPv6.

    Searching the Internet, including these forums, for an explanation and perhaps a solution, most of the times it is said that (php-)curl can’t connect to wordpress.org. On the command line, e.g. curl api.wordpress.org is successfull. But the IPv6 version, curl -6 api.wordpress.org, is not. WordPress.org appears not to have an IPv6 address.

    The obvious solution would be to make WordPress addressable over IPv6, but I understand that has quite some technical and financial implications. The other option seems to me to alter WordPress in a way that it will only ‘curl’ via IPv4.

    The SaFly Curl Patch does not solve this issue. That also addresses only issues with wordpress.org, though the problem seems to include e.g. Jetpack’s wordpress.com.

    What other explanation can be tested? And if there is no other explanation possible, how to make the problem mended in WordPress?

    Please, prove me wrong?

    Paul

Viewing 2 replies - 1 through 2 (of 2 total)
Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘WordPress doesn’t do IPv6?’ is closed to new replies.