Support » Fixing WordPress » WordPress doesn't accept ftp info

  • Resolved RodC


    I’ve searched the net and here but not found an answer.

    I have a VPS running on Windows 2008 with a number of domains administered by Plesk served out via IIS 7.

    I have installed WordPress in one of the domains, and it all appears to work fine.

    But… when I go to install a new theme, via wordpress, I am asked for the ftp credentials. When I enter them I’m given “FTP hostname is required” even though it is there and correct. I have tried using a standalone ftp client, and also Windows XP command line ftp both of which work fine.

    I’ve tried the domain name on its own, with :21, with and without WWW. I’ve tried the server IP address, local host , localhost:21,,, I’ve also tried putting the values in the wp-config.php file.

    I could just upload the theme zips manualy but I need to give control over choice of themes to somone else who would be unable to do that.

    I have a standalone installation here, under XP using Apache , and that works fine and doesn’t ask for ftp credentials.

    If anyone has an answer I would be very grateful



Viewing 1 replies (of 1 total)
  • ‘morning all

    I’d found many people with this problem, but no resolutions that worked for me.

    Mine is now sorted and this may be the problem for others.

    Assuming that you can ftp to your server using either a ftp client or command line ftp. Then check in a browser whether you can connect to ftp://ftp.<your domain>. If after entering the logon details it fails, either with a vague error (IE5) or “425 – Can’t open data connection” then although port 21 is open on your server for client connections, it is probably blocked by the firewall when accessed via a browser.

    Once this is opened, by you or your hosting company, all might be well.

    I think – might be wrong – that if WordPress gets an error when attempting to ftp, there may be only a limited range of expectations, ie wrong user/password, “FTP hostname is required” with the assumption that failure that is not the former must be the latter.

    This may lead to the confusion I and others have had, where clearly the host name is correct but WordPress says it’s wrong, leading us to miss the obvious. ie WordPress is operating through a browser connection.

    Hope it helps – it did me 🙂



Viewing 1 replies (of 1 total)
  • The topic ‘WordPress doesn't accept ftp info’ is closed to new replies.