Support » Fixing WordPress » WordPress didn’t get installed where I wanted it – can I move it?

  • Hi, I was so impressed with myself for setting up my blog until I noticed that it got installed in a sub-folder. I thought I followed the instructions exactly. Ideally the WordPress blog should have been like my index page. Instead it’s at:

    I wanted it to be at the home page, so that if someone types in they will see my blog. The WordPress folder is in the same directory as the index page, images folder, etc. I’d move it up one level, but there doesn’t appear to be one!

    I’d even be ok with having (tried renaming, but the CSS wasn’t working). Any suggestions would be most appreciated!

    Thanks! 🙂

Viewing 13 replies - 1 through 13 (of 13 total)
  • Take a close look at this:

    Note that you’ve already given WP it’s ‘own’ directory, check out the other steps. You can achieve what you want without moving the core files…

    Check the other articles in the codex if you want to move the core files.

    Thanks! Everything was working great until I got to the part where I need to move the .htaccess file. It’s nowhere to be found… any ideas on where it might be?

    Thanks! 🙂

    It’s probably in the wordpress folder, but you may not be able to see it. Generally .htaccess files are hidden by default.

    If you’re using an ftp client, dig through its help files to find out how to make it show all files. If you’re using your host file manager, it may be a bit more problematic depending on what control panel program your host uses.

    Sometimes the easiest thing to do is navigate to the wordpress installation root, create a new file, name it .htaccess, set the permissions on it to 777, then access the admin section of your blog using your browser, go to Options, click the Permalinks tab, and have wp “do it for you”.

    Then set permissions on the .htaccess file back to 644. That’s safe….

    I didn’t get the .htaccess file moved yet, but had to restart the computer. Now I can’t log in to my own blog! My username, email and password are not recognized.

    Is this likley because I didn’t get the .htaccess file moved yet?

    It’s because you don’t have an index.php. You have a index copy.php. That won’t work. Change it to index.php, then sit in the corner for 5 minutes.

    Ah yes. You were right about the index copy.php, thanks for pointing that out.

    But now for the REALLY dumb move… I thought my username was the same one I have ont this board (which I use for a lot of registrations) but I forgot it was admin. Once I tried logging in with admin, and changing the index.php file, I was able to log in.

    Still have to work on the .htaccess file though. What does the .htaccess file do? My understanding is it controls passwords and such (that’s why I thought it was the problem with my login issues).

    Thanks! 🙂

    WP uses your .htaccess to add rewrite rules for paths/permalinks…

    … and if you’re still on the default Permalinks (Options -> Permalinks) then one isn’t really needed and WP probably hasn’t built it yet.

    Thanks HandySolo, I’m YAA (Yet Again Assuming ;’)

    Ok, thanks! So, if the .htaccess has potentially not been built yet, will it go into the right place automatically (since I now have index.php in the root directory)? Or will I need to move it later?

    How will I know if and when the .htaccess gets built, or under what circumstances will this happen?

    Thanks again! 🙂

    Options:Permalinks Update Permalink Structure, then follow directions at bottom. Check back.

    Ok, that seemed easy enough. I did it twice – the first time I selected the “numeric” option. The message said it couldn’t write to the file, so I had to copy and paste the code it generated. Did that, since there was no .htaccess file (even verified by selecting option to view hidden files), so I made the file and pasted in the 8 lines of code it generated.

    Then my entire site got “internal server error” so I removed it, and it’s back up. Went back to the control panel and selected “default”. Didn’t have to copy or paste any code, but there’s still no .htaccess file.

    Is this also the place where it specifies permissions to allow me upload pictures, etc? At this point, it looks like I have no .htaccess file.

    Any thoughts on what I should do?

    Thanks, 🙂

    Contact your host…

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘WordPress didn’t get installed where I wanted it – can I move it?’ is closed to new replies.