Support » Fixing WordPress » WordPress Default Gallery – Issue

  • I recently transferred my blog to a new server. After the transfer, all my posts that had galleries were now messed up.

    Some were completely missing all the pictures that supposed to be in the post. Others are using full size images instead of the 150×150 thumbnail.

    I checked the FTP to be sure that the images were still in their directories, and they are. So why they aren’t displaying? No idea.

    As for the ones that work… Why are they using full-size and not thumbnail? No idea.

    I tried editing the gallery, when I go to select a size, they are all grayed out except the Full-Size option. and in parenthesis it says 0x0.

    [o] Thumbnail — grayed out
    [o] Medium — grayed out
    [o] Large — grayed out
    [X] Full size (0 × 0) — Forcefully selected

    I tried adding a new post using the same images, creating a new gallery and everything worked perfectly.

    I was wondering if there was an easier way to fixing all my posts other than manually going through them all and re-adding every image to every post.

Viewing 7 replies - 1 through 7 (of 7 total)
  • Thanks, but that isn’t exactly my issue here.

    My thumbnails (150×150) already exist in the uploaded directory.

    For some reason, after switching servers, my wordpress decided to just set all images to full size. Upon further exploring, I noticed these full size images are being scaled to 177 width and height is random.

    Previously, my blog used to take the full size image, and actually create a separate thumbnail file, and link to the full size file.

    Right now, it’s taking the full size image and scaling it down to 177x$random

    When I go into the gallery to select thumbnail, I can’t because it’s grayed out and non selectable.

    It’s currently selecting full size by default. It will not let me choose any other size.

    I also think its weird, that in parenthesis for full size it says (0x0). instead of the actual size.

    I tried going into my media settings. unchecking “Crop thumbnail to exact dimensions (normally thumbnails are proportional)” saving, rechecking. saving.

    still no luck. same crap.

    so i tried changing the thumbnail size. saving. same thing. it keeps scaling the full size image to 177x$random.

    now keep in mind, when i create a new post, everything is fine. but all my previous older posts are MESSED up… I was just wondering if there was an easier way to correct this problem other than recreating theses posts.

    Is there an easy method of utilizing the database via phpmyadmin?

    Did you give the plugin a shot? For every picture or thumbnail, there is meta associated with it in the database. That plugin will delete all database data for those attachments and reinsert it. If the files exist, refreshing that data might work.

    You might also want to check your wp_options table for any references to your previous domain. The easiest way would be to export the table via phpmyadmin and doing a search for your old domain in a text editor.

    I have tried the plugin you suggested, no success.

    Full size 0x0 is still being selected by default. I cannot select any other size.

    It seems as if I’m not the only one having this problem.

    I took the time to search WordPress directly along with Google and haven’t had much success.

    Here are a couple links of people directly from the WordPress site having the same exact issue.

    I was just having a very similar problem – probably due to server moves, the galleries were showing only full sized images and the 0x0 size was being shown as an option but I was clearly missing some other sizes. I regenerated the thumbnails, which gave me back the size options I was missing. I then had to edit and update the post (didn’t change anything but I had to do this step) to get it to render correctly. Thanks for the pointer to the regen plugin!

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘WordPress Default Gallery – Issue’ is closed to new replies.