The Support Forums will be in read-only mode for a scheduled maintenance window on 01 September 2016 14:00 UTC - 20:00 UTC. More information.

WordPress database error: [Table 'blog.wp_options' doesn't exist] (5 posts)

  1. guht
    Posted 11 years ago #

    Stuck on Step 1.... I immediately get these errors during Step 1 of the installation process.

    Warning: Invalid argument supplied for foreach() in c:\inetpub\wwwroot\blog\wp-includes\functions.php on line 355

    WordPress database error: [Table 'blog.wp_options' doesn't exist]
    SELECT option_value FROM wp_options WHERE option_name = 'permalink_structure'

    As you can see it is complaing because when it trys to execute the query it cant because the table it is trying to query doesnt exist. I confirmed that it doesnt exist through MySql client, and phpMyAdmin.

    The config file is correct.. I doubled and triple checked it.. I have gotten phpMyAdmin working with the same values. I have even used a test php script with the values found in config file to actually create the missing table. So the account appears to have to correct permissions to alter database. However I have tried using root account also, and still get same errors. I could manually create all the tables and populate them, but that would be ALOT of work, and if I populate something wrong it could hose the whole install.

    Anyone have ANY ideas or suggestions. How can I debug some of php scripts to find out where/how/why its not creating these tables?


  2. omann0
    Posted 11 years ago #

    my suggestion is to clear all wp tables, remove the wordpress installation, redownload and reupload, and try intalling again.

  3. guht
    Posted 11 years ago #

    what wp_ tables? The install script never created any...

    It looks like the file upgrade-schema.php is the one that has the commands that 'SHOULD' create the tables and populate the table wp_options, but I dont know if that file is even being execute or called by the install.php script.

  4. guht
    Posted 11 years ago #

    Actually... I just continued through the warnings and filled in the information - it seems to work now except im getting permissions 403 error when trying to view login page...

    I think that has to do with how directory is setup in IIS..

  5. jlivingston
    Posted 11 years ago #

    Did you ever fix this issue of the errors on the install screen? I'm having the same issues. If I go through and set the blog up it's really slow. I'm hosting it on a windows platform (iis6, php 4...). Any help would be appreciated.

Topic Closed

This topic has been closed to new replies.

About this Topic


No tags yet.