Support » Plugin: Slimstat Analytics » WordPress database error (s)

  • Resolved nextstep

    (@nextstep99)


    Hi, I am getting error messages when I have wpdebug = true. I cannot say for sure when it first started as I only checked the debug when running down some other errors. I have C&Pd the error messages below:

    —-

    WordPress database error: [Can’t DROP ‘plugins’; check that column/key exists]
    ALTER TABLE xxxxx_slim_stats DROP COLUMN plugins

    WordPress database error: [Duplicate column name ‘fingerprint’]
    ALTER TABLE xxxxx_slim_stats ADD COLUMN fingerprint VARCHAR(256) DEFAULT NULL AFTER language

    WordPress database error: [Duplicate column name ‘fingerprint’]
    ALTER TABLE xxxxx_slim_stats_archive ADD COLUMN fingerprint VARCHAR(255) DEFAULT NULL AFTER language

    WordPress database error: [Duplicate column name ‘tz_offset’]
    ALTER TABLE xxxxx_slim_stats ADD COLUMN tz_offset SMALLINT DEFAULT 0 AFTER outbound_resource

    WordPress database error: [Duplicate column name ‘tz_offset’]
    ALTER TABLE xxxxx_slim_stats_archive ADD COLUMN tz_offset SMALLINT DEFAULT 0 AFTER outbound_resource

    —-

    At the moment I am considering removal of the plugin, cleaning the DB of all slim_stat tables and then re-installing the plugin, but I am loathe to lose the stats.

    Any suggestions?

    Many thanks, and also, thank you for the plugin. It is superb!

    PS I should mention that I have tested the error message with all other plugins deactivated and with theme Twenty Nineteen.

    • This topic was modified 1 month, 3 weeks ago by  nextstep.
Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author Jason Crouse

    (@coolmann)

    Hi @nextstep99

    thank you for your kind words, I’m glad you find Slimstat useful!

    First things first: DO NOT UNINSTALL Slimstat, or you will lose all your data.

    These errors you’re getting seem to be related to inability of the plugin to save the new version number in the database, which stops the attempts to update the database. If you look at phpMyAdmin, there’s a table called wp_options, and inside there’s a row called slimstat_options:

    SELECT * FROM wp_options WHERE option_name = ‘slimstat_options’

    At the very beginning of the value string, there should be something that says:

    a:81:{s:7:”version”;s:7:”4.8.7.2″;s…

    Please make sure that the version number in that string matches your Slimstat version. Noticed that number s:7 before the version itself? That’s the number of characters in the following string, so if your version number is 4.8.7, change s:7 to s:5 as well.

    I hope this helps. If it doesn’t don’t hesitate to send me a message via https://support.wp-slimstat.com/ and we will dig deeper into your issue.

    Jason.

    [SOLVED]

    Hello Jason, and thank you for this info. You were spot on, the DB and plugin versions did not match. I adjusted as you suggested and <BOOM> Mission Accomplished!

    I have just sent a $50 donation via your donation link.

    https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=BNJR5EZNY3W38

    Thanks again!

    Plugin Author Jason Crouse

    (@coolmann)

    Hi @nextstep99

    I’m really glad it worked, and THANK YOU SO MUCH for your donation, it’s definitely appreciated!

    Best,
    Jason

    Warning: mysqli_num_fields() expects parameter 1 to be mysqli_result, boolean given in /home/oddtmkkw/wwggww.com/wp-includes/wp-db.php on line 3283

    Hi everyone, I am new to the community, I have been trying to start a new topic or find one related to my issue but no luck, I am not sure if I am having a php code issue but there is an error on my homepage that reads :
    Warning: mysqli_num_fields() expects parameter 1 to be mysqli_result, boolean given in /home/oddtmkkw/wwggww.com/wp-includes/wp-db.php on line 3283
    any help will be greatly appreciated.
    http://www.wwggww.com

    Plugin Author Jason Crouse

    (@coolmann)

    Dear @saf0,

    you may want to start here:

    Common WordPress Errors

    and if you can’t solve the issue, please post a support request here:

    https://wordpress.org/support/forum/how-to-and-troubleshooting/

    Someone seems to have encountered a similar issue a few years ago:

    https://wordpress.org/support/topic/warning-mysqli_num_fields-error-with-w3-cache-plugin-on-my-site/page/2/

    Best,
    Jason

    • This reply was modified 1 month, 3 weeks ago by  Jason Crouse.
Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.