WordPress.org

Forums

[resolved] WordPress database error: [Field 'link_notes' doesn't have a default value] (9 posts)

  1. yesitookmypills
    Member
    Posted 9 years ago #

    Hi i'm trying to install wp, but at the second step i get these errors:

    WordPress database error: [Field 'link_notes' doesn't have a default value]
    INSERT INTO wp_links (link_url, link_name, link_category, link_rss) VALUES ('http://blog.carthik.net/index.php', 'Carthik', 1, 'http://blog.carthik.net/feed/');

    WordPress database error: [Field 'link_notes' doesn't have a default value]
    INSERT INTO wp_links (link_url, link_name, link_category, link_rss) VALUES ('http://blogs.linux.ie/xeer/', 'Donncha', 1, 'http://blogs.linux.ie/xeer/feed/');

    WordPress database error: [Field 'link_notes' doesn't have a default value]
    INSERT INTO wp_links (link_url, link_name, link_category, link_rss) VALUES ('http://zengun.org/weblog/', 'Michel', 1, 'http://zengun.org/weblog/feed/');

    WordPress database error: [Field 'link_notes' doesn't have a default value]
    INSERT INTO wp_links (link_url, link_name, link_category, link_rss) VALUES ('http://boren.nu/', 'Ryan', 1, 'http://boren.nu/feed/');

    WordPress database error: [Field 'link_notes' doesn't have a default value]
    INSERT INTO wp_links (link_url, link_name, link_category, link_rss) VALUES ('http://photomatt.net/', 'Matt', 1, 'http://xml.photomatt.net/feed/');

    WordPress database error: [Field 'link_notes' doesn't have a default value]
    INSERT INTO wp_links (link_url, link_name, link_category, link_rss) VALUES ('http://zed1.com/journalized/', 'Mike', 1, 'http://zed1.com/journalized/feed/');

    WordPress database error: [Field 'link_notes' doesn't have a default value]
    INSERT INTO wp_links (link_url, link_name, link_category, link_rss) VALUES ('http://www.alexking.org/', 'Alex', 1, 'http://www.alexking.org/blog/wp-rss2.php');

    WordPress database error: [Field 'link_notes' doesn't have a default value]
    INSERT INTO wp_links (link_url, link_name, link_category, link_rss) VALUES ('http://dougal.gunters.org/', 'Dougal', 1, 'http://dougal.gunters.org/feed/');

    WordPress database error: [Field 'category_description' doesn't have a default value]
    INSERT INTO wp_categories (cat_ID, cat_name, category_nicename) VALUES ('0', 'Uncategorized', 'uncategorized')

    WordPress database error: [Field 'post_excerpt' doesn't have a default value]
    INSERT INTO wp_posts (post_author, post_date, post_date_gmt, post_content, post_title, post_category, post_name, post_modified, post_modified_gmt) VALUES ('1', '2005-10-03 21:32:49', '2005-10-03 19:32:49', 'Welcome to WordPress. This is your first post. Edit or delete it, then start blogging!', 'Hello world!', '0', 'hello-world', '2005-10-03 21:32:49', '2005-10-03 19:32:49')

    Dunno what to do ... i searched around to solve this problem but i couldn't find a thing.

    MySQL5 and apache(2) (with mod_rewrite) and php5 are working. I used them with mt. But i wish to switch to wp.

    Thanks a lot

  2. jaseone
    Member
    Posted 9 years ago #

    MySQL 5 is pretty new (it is still in Beta isn't it?) and WordPress probably doesn't play nicely with it yet as it likely enforces a lot more relational integrity than MySQL 4.1 does.

    I couldn't find any specific information on Google though but the columns it is complaining about are all set so MySQL should prevent a row being inserted if there is no value specified for those columns and those columns don't have a default value either.

    I would have expected that to fail in MySQL 4.1 as well but apparently it doesn't as I have a lot of nulls in those columns myself so 5.0 must fix that "little" bug.

    I'd recommend not trying to install on MySQL 5 unless you can go through and make the required changes to the schema yourself.

  3. yesitookmypills
    Member
    Posted 9 years ago #

    well then, i'll try with mysql 4

    Thanks again

  4. slynn
    Member
    Posted 9 years ago #

    I had this same problem with MySQL 5.0.13-rc-Max. After some investigation, I found that it is not a 'bad' thing. It did not insert those records into the table. It is one of the many strange things that I have found using MySQL5...

    The work around, is to just insert those records by hand and add the column that it says does not have a default value and force the field to ''. Here are all the queries.

    INSERT INTO wp_links (link_url, link_name, link_category, link_rss, link_notes) VALUES ('http://blogs.linux.ie/xeer/', 'Donncha', 1, 'http://blogs.linux.ie/xeer/feed/', '');

    INSERT INTO wp_links (link_url, link_name, link_category, link_rss, link_notes) VALUES ('http://zengun.org/weblog/', 'Michel', 1, 'http://zengun.org/weblog/feed/', '');

    INSERT INTO wp_links (link_url, link_name, link_category, link_rss, link_notes) VALUES ('http://boren.nu/', 'Ryan', 1, 'http://boren.nu/feed/', '');

    INSERT INTO wp_links (link_url, link_name, link_category, link_rss, link_notes) VALUES ('http://photomatt.net/', 'Matt', 1, 'http://xml.photomatt.net/feed/', '');

    INSERT INTO wp_links (link_url, link_name, link_category, link_rss, link_notes) VALUES ('http://zed1.com/journalized/', 'Mike', 1, 'http://zed1.com/journalized/feed/', '');

    INSERT INTO wp_links (link_url, link_name, link_category, link_rss, link_notes) VALUES ('http://www.alexking.org/', 'Alex', 1, 'http://www.alexking.org/blog/wp-rss2.php', '');

    INSERT INTO wp_categories (cat_ID, cat_name, category_nicename, category_description) VALUES ('0', 'Uncategorized', 'uncategorized', '')

    INSERT INTO wp_posts (post_author, post_date, post_date_gmt, post_content, post_title, post_category, post_name, post_modified, post_modified_gmt, post_excerpt) VALUES ('1', '2005-10-03 21:32:49', '2005-10-03 19:32:49', 'Welcome to WordPress. This is your first post. Edit or delete it, then start blogging!', 'Hello world!', '0', 'hello-world', '2005-10-03 21:32:49', '2005-10-03 19:32:49', '')

  5. yesitookmypills
    Member
    Posted 9 years ago #

    thanks a lot but it's laaaaaate :)
    i just uninstalled mysql5, and it works with mysql4.1

    thanks again
    \o

  6. wojie
    Member
    Posted 9 years ago #

    anyone know how to make this happen automatically with every post? namely, how to configure mysql 5 to allow null values for those columns? I'd hate to have to cut and paste the offending sql statement into the console every time i'd like to post a new entry.

    thanks

  7. jefflundberg
    Member
    Posted 9 years ago #

    I tried allowing NULLs in all the fields without default values (in every table). This allows me to add posts. However, I can't seem to change the default password.

  8. dr_njt
    Member
    Posted 9 years ago #

    I found this solution to fix this issue:

    MySQL 5 uses a strict mode which needs to be disabled.
    In Windows, Goto Start-->Programs-->MySQL->MySQL Instance Config Wizard. Follow through the Reconfigure Instance option-->Detailed Configuration-->Continue Next a few screens. At the bottom under Enable TCP/IP option there is 'Enable Strict Mode'. Deslect this option (no tick). Save changes and MySQL will restart.

    Since WordPress had problems generating the database on the previous setup (above) I deleted the blog database in PhPMyAdmin and created a new one. I then re-run the WordPress setup and allowed WordPress to recreate all the tables again from scratch. No problems or errors generated. WordPress seems to post and change the default password etc

  9. dazern
    Member
    Posted 9 years ago #

    Thank you !I had solved the issue!
    Thanks again!

Topic Closed

This topic has been closed to new replies.

About this Topic