Support » Plugin: Wordfence Security - Firewall & Malware Scan » WordPress database error Deadlock for query INSERT IGNORE INTO `wp_wfConfig`

  • Resolved jonathanmoorebcsorg

    (@jonathanmoorebcsorg)


    Anyone else seeing errors like this in the wordpress error logs recently?

    WordPress database error Deadlock found when trying to get lock; try restarting transaction for query INSERT IGNORE INTO wp_wfConfig (name, val, autoload) VALUES (‘wfSyncGeoIP.lock’, ‘1541827733’, ‘no’)

Viewing 7 replies - 1 through 7 (of 7 total)
  • wfasa

    (@wfasa)

    Hi Jonathan,
    A couple of customers have reported this and we’ve made a bit of progress on debugging it. We think it may be happening on sites where the GeoLite2-Country.mmdb (The GeoIP country database) fails to sync as it should.

    I’m not sure how comfortable you are modifying the database directly via phpMyAdmin but if you are, you can try this

    1. Delete GeoLite2-Country.mmdb file located in wflogs
    2. Delete “_transient_timeout_wfSyncGeoIPActive” and “_transient_wfSyncGeoIPActive” from the wp_options table

    If that works, let me know!

    Plugin Support wfdave

    (@wfdave)

    Hi @jonathanmoorebcsorg,

    We haven’t heard back from you in a while, so I’ve gone ahead and marked this thread as resolved. Please feel free to open another thread if you’re still having issues with Wordfence!

    Thanks!

    Hi, I did take the recommended actions around 1 december, but still seeing these pop up in the logs:

    [07-Dec-2018 14:09:16 UTC] WordPress database error Deadlock found when trying to get lock; try restarting transaction for query INSERT IGNORE INTO wp_wfConfig (name, val, autoload) VALUES (‘wfSyncGeoIP.lock’, ‘1544191756’, ‘no’) made by require(‘wp-blog-header.php’), require_once(‘wp-load.php’), require_once(‘wp-config.php’), require_once(‘wp-settings.php’), do_action(‘plugins_loaded’), WP_Hook->do_action, WP_Hook->apply_filters, wordfence::veryFirstAction, wfConfig::createLock
    [07-Dec-2018 14:09:16 UTC] WordPress database error Deadlock found when trying to get lock; try restarting transaction for query INSERT IGNORE INTO wp_wfConfig (name, val, autoload) VALUES (‘wfSyncGeoIP.lock’, ‘1544191756’, ‘no’) made by require(‘wp-blog-header.php’), require_once(‘wp-load.php’), require_once(‘wp-config.php’), require_once(‘wp-settings.php’), do_action(‘plugins_loaded’), WP_Hook->do_action, WP_Hook->apply_filters, wordfence::veryFirstAction, wfConfig::createLock
    [07-Dec-2018 14:09:16 UTC] WordPress database error Deadlock found when trying to get lock; try restarting transaction for query INSERT IGNORE INTO wp_wfConfig (name, val, autoload) VALUES (‘wfSyncGeoIP.lock’, ‘1544191756’, ‘no’) made by require(‘wp-blog-header.php’), require_once(‘wp-load.php’), require_once(‘wp-config.php’), require_once(‘wp-settings.php’), do_action(‘plugins_loaded’), WP_Hook->do_action, WP_Hook->apply_filters, wordfence::veryFirstAction, wfConfig::createLock
    [07-Dec-2018 16:16:35 UTC] WordPress database error Deadlock found when trying to get lock; try restarting transaction for query INSERT IGNORE INTO wp_wfConfig (name, val, autoload) VALUES (‘wfSyncGeoIP.lock’, ‘1544199395’, ‘no’) made by require(‘wp-blog-header.php’), require_once(‘wp-load.php’), require_once(‘wp-config.php’), require_once(‘wp-settings.php’), do_action(‘plugins_loaded’), WP_Hook->do_action, WP_Hook->apply_filters, wordfence::veryFirstAction, wfConfig::createLock
    [07-Dec-2018 16:16:35 UTC] WordPress database error Deadlock found when trying to get lock; try restarting transaction for query INSERT IGNORE INTO wp_wfConfig (name, val, autoload) VALUES (‘wfSyncGeoIP.lock’, ‘1544199395’, ‘no’) made by require(‘wp-blog-header.php’), require_once(‘wp-load.php’), require_once(‘wp-config.php’), require_once(‘wp-settings.php’), do_action(‘plugins_loaded’), WP_Hook->do_action, WP_Hook->apply_filters, wordfence::veryFirstAction, wfConfig::createLock
    [07-Dec-2018 16:16:35 UTC] WordPress database error Deadlock found when trying to get lock; try restarting transaction for query INSERT IGNORE INTO wp_wfConfig (name, val, autoload) VALUES (‘wfSyncGeoIP.lock’, ‘1544199395’, ‘no’) made by require(‘wp-blog-header.php’), require_once(‘wp-load.php’), require_once(‘wp-config.php’), require_once(‘wp-settings.php’), do_action(‘plugins_loaded’), WP_Hook->do_action, WP_Hook->apply_filters, wordfence::veryFirstAction, wfConfig::createLock
    [08-Dec-2018 01:16:49 UTC] WordPress database error Deadlock found when trying to get lock; try restarting transaction for query INSERT IGNORE INTO wp_wfConfig (name, val, autoload) VALUES (‘wfSyncGeoIP.lock’, ‘1544231809’, ‘no’) made by require(‘wp-blog-header.php’), require_once(‘wp-load.php’), require_once(‘wp-config.php’), require_once(‘wp-settings.php’), do_action(‘plugins_loaded’), WP_Hook->do_action, WP_Hook->apply_filters, wordfence::veryFirstAction, wfConfig::createLock

    Same problem here for some weeks.
    No fixes so far.
    Any idea?

    still ongoing..

    Same here…
    I am getting this error

    INSERT INTO photo_wfConfig (name, val, autoload) values (‘lastNotificationID’, ‘1’, ‘no’)
    +
    wfConfig::atomicInc()
    Plugin: wordfence Duplicate entry ‘lastNotificationID’ for key ‘PRIMARY’ 1062

    not seen this more recently, assume it is resolved with other updates since this discussion

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘WordPress database error Deadlock for query INSERT IGNORE INTO `wp_wfConfig`’ is closed to new replies.