Support » Themes and Templates » WordPress Database Error

  • Hi, I just tried using the “Tiga” theme, and I really like it alot, but at the bottom-left side of the page, I get the following error:

    WordPress database error: [Table ‘db218710388.wp_categories’ doesn’t exist]
    SELECT cat_id, cat_name FROM wp_categories WHERE link_count > 0

    Any idea how I can fix this?

    Thanks in advance!

Viewing 13 replies - 1 through 13 (of 13 total)
  • Moderator Samuel Wood (Otto)

    (@otto42) Admin

    Any idea how I can fix this?

    Three ways:
    1. Edit the Tiga theme and fix it by replacing the bad code with good code.
    2. Try to get the author of the Tiga theme to fix it to be 2.3 compatible.
    3. Don’t use the Tiga theme.

    In that case, step 3 is obviously common sense.

    step 3 isn’t a good option because I can’t find a way to locate the author, I’ve already tried.

    Step 1 is probably the answer I’m looking for. (ie: What is the “good code”?)

    Moderator Samuel Wood (Otto)

    (@otto42) Admin

    That’s hard to say. Without looking at the Tiga theme itself, I can’t tell you. Care to provide a link to the specific version you’re using?

    Sure, it says Tiga version 1.0.2, and this is the one I’m using:

    the problem is with the blogroll area i guess, it shows up fine on the test run, but not on my site (where it spits out the error message instead).

    Moderator Samuel Wood (Otto)

    (@otto42) Admin

    That site looks like a test site, it doesn’t have anything for me to download and look at.

    When WordPress updated to 2.2 with installed widgets, it broke the Tiga theme and the developer is non-responsive. However, someone else was kind enough to figure out how to fix it by offering a replacement code for the sidebars. You can find it here:

    I’m in the middle of testing my themes and plugins with 2.3 and am not having problems with tiga. (I am having trouble removing widgets once I have added them to a sidebar in FF but not IE. Not sure if problem is related to tiga or not – about to test other themes.)


    I just released a patch that (hopefully) fixes this issue with the Tiga theme under WordPress 2.3.

    WordPress Tiga theme 2.2 / 2.3 upgrade

    I tried it on my test install of 2.3 and it seems to work fine. If it doesn’t work for you, post a message on my blog and let me know.

    Hi guys,

    Im running the Tiga theme over at – Your 2.3 upgrade has fixed the issue with WP_Categories error that I was receiving in the sidebar; but I still cannot move widgets around and see them update. To actually move a widget either left or right, and to see it moved; i have to select another theme, then back to tiga theme and the widgets are magically moved where i put them under the “widgets” menu. Can you please help?

    Appreciate it!

    Ps – Otto’s old fix for this problem worked for me when I was running 2.2 – although I tried the same fix, and it didnt work under 2.3

    The widgets seem to be working fine for me. I can rearrange their order within a given sidebar, or move them from the left to right sidebar or vice versa. I am running Firefox under WinXP.

    Can you give me some more information about what exactly you are seeing?

    Basically when I move widgets around, they don’t register when I refresh the page. Under the Widgets section, they are definetley moved but not on the actual page.

    I don’t think this is a theme issue, because I cannot seem to move the widgets on any of my themes. I have to actually SWITCH themes for the change to occur, when it should be a live fix.

    I am also running Firefox under Windows Vista

    I fixed the issue. Apparently when I “upgraded” to 2.3 it caused some malfunctions or something within my wordpress code. I basically backed up my whole blog, then just redeployed it. I reinstalled your patch and its all good. Thanks!

    (Suggestion: Dreamhost 2.2 -> 2.3 isn’t flawless)

    Glad to hear you got it sorted out.

    Hi, its me again. Well I’ve patched the tiga theme and its working great…The only issue I’m having now is that I cannot get the editor to format my text correctly. Even if I insert break html into the editor, it just doesnt want to give me line breaks.

    I have even tried disabling the editor, but that doesnt work either. When I switch to another theme, the formatting is corrected, so i think this issue lies within some of the tiga code. Can anyone help me solve this issue please?

    Thanks in advance… =^..^=

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘WordPress Database Error’ is closed to new replies.