Support » Installing WordPress » WordPress Database Error

  • Hello there,

    This is the second time I try to upgrade WordPress from 1.2.2 to 1.5. And second time it does not work.

    Here is the error I have when I launch the file : upgrade.php

    WordPress database error: [You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near ‘-categories ( cat_ID bigint(20) NOT NULL auto_increment, ca]
    CREATE TABLE wp-categories ( cat_ID bigint(20) NOT NULL auto_increment, cat_name varchar(55) NOT NULL default ”, category_nicename varchar(200) NOT NULL default ”, category_description longtext NOT NULL, category_parent int(4) NOT NULL default ‘0’, PRIMARY KEY (cat_ID), KEY category_nicename (category_nicename) )

    I have this error for nearly all the scripts that the upgrade launches… Any idea ?

Viewing 3 replies - 1 through 3 (of 3 total)
  • I would first backup the database. Keep that safe.

    Without going to 1.5, just run upgrade.php anyway – it will not harm your code. Post back what happens ?
    (You must do this with just 1.2.2 code though, not 1.5)

    I did the backup (even though i don’t know how to load it back anyway.. but that’s another story…

    I launched the upgrade.php file and here is where I go :

    This file upgrades you from any previous version of WordPress to the latest. It may take a while though, so be patient.
    Upgrade WordPress »

    Looks good, doesn’t it ?

    By the way, Im’ sorry, but I quite don’t understand the statement you put into brackets… What do you mean ??

    Thx for you help…

    ok. I have done it. My error comes from something incorrect in the wp-config.php. Please for the readers of this post : DO copy the wp-config.php from the former version of your site. And everything will go fine.

    Thx for the help.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘WordPress Database Error’ is closed to new replies.