Support » Fixing WordPress » WordPress database error

  • the landing page on my blog is giving me a wierd error at the top and i have no idea what it is. this is what it’s saying:

    WordPress database error: [You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near ‘1o’ at line 1]
    SELECT DISTINCT * FROM wp_posts WHERE 1=1 AND post_date_gmt <= ‘2005-06-16 03:39:59’ AND (post_status = “publish”) GROUP BY wp_posts.ID ORDER BY post_date DESC LIMIT 0, 1o

    my blog is here: http://blog.letmefall.com/

    thanks in advance for any help. 🙂

Viewing 14 replies - 16 through 29 (of 29 total)
  • I’ve done as I said..reinstalled wordpress..I hadn’t made any mistakes I can identfy, I get the same results
    http://www.disyasite.com/weblog/wp-admin/install.php

    I would imagine the issue is serverside.

    Anyone got another angle?

    Mark (podz)

    (@podz)

    Support Maven

    Paste your wp-config.php here ?
    (but REMOVE your password)

    // ** MySQL settings ** //
    define(‘DB_NAME’, ‘campfad’); // The name of the database
    define(‘DB_USER’, ‘campfad’); // Your MySQL username
    define(‘DB_PASSWORD’, ‘password’); // …and password
    define(‘DB_HOST’, ‘localhost’); // 99% chance you won’t need to change this value

    Mark (podz)

    (@podz)

    Support Maven

    Okay ….. the DB_NAME looks wrong.
    It usually has something before that – with a site of mine, it is the domain name before the db_name, with another it’s the user name.
    That is where I would check your site first.

    Could you say that anotherway please? Im not understanding you.

    Mark (podz)

    (@podz)

    Support Maven

    Did you follow the first link I gave up the top of this thread ?

    I think I’m leaving this till I can talk to my host again.
    There is no indication in the folders that mySQL is installed..Thanks for your suggestions so far.

    Uusally there “no indication” in the folders about the presence of the MySQL. It might even be on a different server (as happens with many hosts).

    the last thing i remember changing is how many posts to show i once. then it went all wacky on me. i have no idea how to look for code that’s not in place or anything. i’ve looked at everything…but i’m still not sure of what exactly i should be looking for.

    well after a bit of playing around, i went back to options, made a quick change and it’s restored. heh, i hate when stupid things like that happen. thanks for the help! 🙂

    I contacted my host today who once again is insistent that the MYSQL is set up and ready.

    Does wordpress demand the existence of an apache module to run???

    My hosting is on an NT server that is not runing apache mods…

    I’m wondering if this is really my problem. I was told that wordpress would run properly on an NT server.

    My host kept on insisting I upload the wordpress database to the folder myself…I wonder where the database is supposed to come from? I gather the install routine of wordpress creates the database itself…Is that correct?

    To distill the question “Can I run wordpress on an NT server without the apache module?”

    Yes, you can run WordPress on IIS instead of Apache:
    http://cornwall.backtalk.com/archives/2004/07/07/15/16/31/

Viewing 14 replies - 16 through 29 (of 29 total)
  • The topic ‘WordPress database error’ is closed to new replies.