Support » Alpha/Beta/RC » WordPress database error

  • Resolved merkurov

    (@merkurov)


    I’m upgrade to 2.0, run upgrade.php, but on every post i see message:

    WordPress database error: [Unknown column ‘user_level’ in ‘where clause’]
    SELECT COUNT(*) FROM blog_users WHERE user_level > 2

    (theme: k2)
    how fix it?

Viewing 3 replies - 1 through 3 (of 3 total)
  • Moderator James Huff

    (@macmanx)

    Please submit your support request to the K2 Support Forums:

    http://flickr.com/groups/binarybonsai/

    Macmanx is correct in saying that K2 isn’t supported in this forum.

    The cause of the problem is that WP2.0 no longer has a user_level column as it’s moved to a role-based permissions from the older numeric user level design.

    However, bear in mind that both WP2.0 and K2 are beta so things will break. This is not an upgrade but a means to test functionality.

    And a final note, Michael Heilmann has already stated in his forum that K2 was not developed with 1.6 alpha or 2.0 beta in mind, but will be 2.0 final compliant(and won’t work retro to 1.5.2). So don’t expect any quick fixes…

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘WordPress database error’ is closed to new replies.