WordPress.org

Support

Support » Plugins and Hacks » WordPress Database Backup Plugin

WordPress Database Backup Plugin

Viewing 15 replies - 16 through 30 (of 74 total)
  • See Podz’s response, immediately above mine. If you’re using FTP, tell us which FTP client you use and we’ll try to help.

    Well I thought I had a revelation…but then more problems. Part of the issue is that there was no backup folder in the wp-content directory. I created a new folder named “backup” then right clicked on it and enabled read/write and execute for owner only. That did get rid of the “not writable” error. Then when I tried to back it up I got a TON of errors:

    A bunch of these:
    Warning: fwrite(): supplied argument is not a valid stream resource in:
    a database error and
    a few of these

    Warning: fwrite(): supplied argument is not a valid stream resource in /home/content/c/h/e/cherylkemp/html/blog/wp-content/plugins/wp-db-backup.php on line 155

    It is such a long list I wasn’t sure whether I should post it here or not. I usually just use the “my network places” in windows for ftp and I also have Frontpage 2003, although I haven’t really been suing it much since I got WordPress going…easier just to do the simple ftp.

    Thanks.

    It also give this statement: Backup Successful!
    Your backup file: cherylkemp_wp_20050802_797.sql should begin downloading shortly.

    then this after I click the link cherylkemp…etc: Forbidden
    You don’t have permission to access /blog/wp-content/backup/cherylkemp_wp_20050802_797.sql on this server.

    Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

    installed it. when i look at the downloaded file, should it look all messy?

    Oh…sorry I didn’t try this sooner. I had checked all of the following boxes for additional components:
    You may choose to include any of the following tables:
    sk2_blacklist
    snipe_gallery_cat
    snipe_gallery_data
    snipe_gallery_frames
    wp_bad_behavior_log
    wp_sk2_logs
    wp_sk2_spams

    If I don’t check any of them, it works. It would be great though if there is a way to do it all at once.

    Sorry for the multiple posts

    pineapplemike: did you select gzip compression? If you did, then yes it should look messy. Unzip it first.

    oncidium: did you read the included wp-db-backup.txt ? I explain the documentation why I will not support automatic selection of all the additional tables.

    no I didn’t read it but I will.

    Guess that means there is no easy way…with that many errors there is no way I can figure it out (nor would it be worth the timek). I think I finally did get myPHP to save it like I wanted. I just want to make sure when I switch servers, I don’t mess anything up.

    There’s no reason to backup the following tables if you’re moving servers:
    sk2_blacklist
    wp_bad_behavior_log
    wp_sk2_logs
    wp_sk2_spams

    All of the information in those tables is likely to change with some regularity.

    In wp-db-backup 1.5 I get the error message:

    “The script to backup your database is too large for PHP to load entirely into memory, and so cannot be compressed within PHP.
    Your database was too large to compress.
    Your backup has been saved uncompressed.”

    I read on Skippy dot net about PHP memory limit, but that can’t be it because I have don’t have more than a few posts. Besides… It worked before. I think it stopped working when I upgraded to the latest version. Any ideas why? I guess I don’t need to have it zipped, but it’s a bit annoying that the gzip feature is always selected. I just know that I’ll try it once each time before I remember to uncheck it.

    TH, I have exactly the same problem: very small number of total posts; initially the plugin compressed my .sql backups; now (starting a week later) it returns the “too large for PHP to load entirely into memory” message. What gives?

    The changed behavior very likely coincided with my upgrading to version 1.5.

    I’d love to know if this can be fixed.

    TH and tqn69, yeah I’ve had the same problem (I’m running WP 1.5) but if I uncheck the gzip feature, I don’t get the error.

    Hoover, agreed. However, I prefer getting a compressed backup since I’m having them sent daily to my Gmail account. It’d save bandwidth.

    tqn69, yeah I know what you mean. I’m sure Skippy will fix the issue in the next release.

    Well… HooverDST, I’m sure you’re right about that. This all indicates that there are more of us with this problem. For once I think I have actually been the victim of a bug and not my own stupidity (that tends to screw up even the most simple directions).

    Guys, I found something that will help. Looks like someone has updated the code in Skippy’s absence (he’s on vacation apparently). I’ve installed this and gzip works again (Whoopee!), and allows really huge blogs to be backed up irrespective of the server’s memory limits. Apparently the file is being hosted at the moment at redalt.com

    Asymptomatic » Blog Archive » WordPress Database Backup v1.5
    http://asymptomatic.net/wp/2005/07/22/1775/wp-database-backup-v15/

Viewing 15 replies - 16 through 30 (of 74 total)
  • The topic ‘WordPress Database Backup Plugin’ is closed to new replies.