Support » Plugin: Stream » WordPress Dashboard is broken/empty when Stream is activated!

Viewing 10 replies - 1 through 10 (of 10 total)
  • Plugin Author Japh

    (@japh)

    Hi Bart,

    Thanks for reporting this! Would you mind telling us what other plugins you have installed and active?

    Also, if possible, it’d be useful to see the HTML source code of the Dashboard page when this is happening. If you’re able to share that, it’d be best to paste it either into a Gist on GitHub or a site like pastie.org (rather than just pasting a huge chunk of HTML here in the forum).

    Thanks again, and hopefully with your help we’ll have a fix soon!

    Cheers,
    Japh

    Japh,

    I disabled all other plugins and the bug persists.

    Here’s a Pastie of the dashboard’s htmm: http://pastie.org/9218044

    thanks for the quick follow-up!

    Bart

    Plugin Author Luke Carbis

    (@lukecarbis)

    Hi Bart,

    What version of PHP are you using?

    The next step is to try turning WP_DEBUG on. To turn on debug mode, edit your wp-config.php file and add this line:

    define('WP_DEBUG', true);

    It goes just before the line that says:
    /* That's all, stop editing! Happy blogging. */

    With this on, do you get an error? Could you please post your Dashboard’s HTML again with WP_DEBUG on?

    Thanks,
    Luke

    Luke,

    No idea about the PHP version because I’m on a managed WordPress hosting service from Flywheel. http://getflywheel.com/

    I can’t call phpinfo(); either. Any other idea how I might find out what version I’m on?

    Here’s a Gist with WP_DEBUG on. Let’s hope it helps you out.

    https://gist.github.com/bartdevuyst/2266b6104aaf91ab9199

    thanks,

    Bart

    Plugin Author Frankie Jarrett

    (@fjarrett)

    Hello everyone,

    I did not see anywhere yet what version of Stream this is, but I assume it’s the latest version, which is v1.4.5.

    In this version there was a fatal error introduced when attempting to activate Stream when running PHP 5.2 or lower. This is most likely the cause of the problem being experienced here. Stream requires PHP 5.3 or higher.

    You should install and activate the Send System Info plugin and paste your “Remote Viewing” URL here.

    Hi Frankie,

    it’s the latest, 1.4.5.

    Here’s my system info, apparently I’m using PHP 5.5.

    Home

    Hi Stream,

    just an update to tell you that Stream 1.4.6 didn’t fix this issue! 😉

    Bart

    Plugin Author Frankie Jarrett

    (@fjarrett)

    Hi Bart, just circling back to this as we still can’t seem to replicate the problem properly.

    I’ve just been inspecting your latest gist and I don’t see any PHP errors in your source code anywhere, which leads me to think that WP_DEBUG may in fact not have been turned on when you copied the source code of the page.

    I can see that your page stops loading at the Stream dashboard widget, however, you should be seeing debug information at this point telling you what PHP warning is causing it to fail.

    I know by looking at your system info right now that WP_DEBUG is defintely disabled, would you mind turning it back on, reloading your dashboard and pasting any errors you see here?

    Thanks!

    Thanks for the follow-up, Frankie.

    You’re right about the WP_DEBUG. Here’s a new Gist with WP_DEBUG on. https://gist.github.com/bartdevuyst/95920974a397167d1010

    Also, with WP_DEBUG on I’ve got no errors whatsoever on the dashboard.

    greetings,

    Bart

    Plugin Author Frankie Jarrett

    (@fjarrett)

    OK thanks, Bart.

    I suppose the next step will be to check your server’s PHP error log directly and see if there is anything happening there.

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘WordPress Dashboard is broken/empty when Stream is activated!’ is closed to new replies.