WordPress.org

Forums

WordPress dashboard broken (26 posts)

  1. hrrubin
    Member
    Posted 1 year ago #

    I'm designing on a wordpress site (I did not install wordpress there) and the dashboard is not working correctly.

    The website: http://www.hollywoodpigerne.dk

    Examples:
    Login screen - looking wrong
    Left menu - hover not working
    Menu items - can't access options

    The installation is version 3.8.1 danish. I have re-intalled the latest version, disabled all plugins and changed theme, but it's having no effect.

    I also tried placing define('SCRIPT_DEBUG', true); or define('CONCATENATE_SCRIPTS', false); in wp-config.php, but the first didn't work and second resulted in an error.

    I'm told it's working in Firefox on mac, but that's no good for the client.

    Any suggestions?

  2. esmi
    Forum Moderator
    Posted 1 year ago #

    Have you tried:

    - deactivating all plugins to see if this resolves the problem. If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    - switching to the default theme to rule out any theme-specific problems.

    - resetting the plugins folder by FTP or PhpMyAdmin. Sometimes, an apparently inactive plugin can still cause problems.

  3. hrrubin
    Member
    Posted 1 year ago #

    Did you read my post? I did all this.

  4. esmi
    Forum Moderator
    Posted 1 year ago #

    Did you read my post?

    Yes

    I did all this.

    Actually, you didn't say whether you tried the default 2014 theme and you didn't try resetting the plugins folder.

  5. hrrubin
    Member
    Posted 1 year ago #

    Now I tried the default 2014 theme and resetting the plugin folder. No effect.

  6. esmi
    Forum Moderator
    Posted 1 year ago #

    Can we see the site using the default Twenty Fourteen theme with all plugins deactivated?

  7. hrrubin
    Member
    Posted 1 year ago #

    Ready

  8. esmi
    Forum Moderator
    Posted 1 year ago #

    Try re-uploading all files & folders - except the root wp-config.php & .htaccess files and the wp-content folder - from a fresh download of WordPress. Make sure that you delete the old copies of files & folder before uploading the new ones.

    Also, re-upload a fresh, unpacked, copy of the theme's folder to wp-content/themes using FTP or whatever file management application your host provides.
    http://wordpress.org/themes/twentyfourteen

  9. hrrubin
    Member
    Posted 1 year ago #

    So I only re-upload the loose files, wp-admin and wp-includes folders?

    And only excluding wp-config.php, .htaccess and wp-content folder?

  10. esmi
    Forum Moderator
    Posted 1 year ago #

    Yes. And yes. Make sure that you delete the old copies of files & folder before uploading the new ones.

  11. hrrubin
    Member
    Posted 1 year ago #

    I have re-uploaded the different files and folders except the one mentioned. I also put an unpacked theme in the theme folder.

    Do I still need to have the twentyfourteen and all plugins off?

  12. esmi
    Forum Moderator
    Posted 1 year ago #

    I also put an unpacked theme in the theme folder.

    The 2014 theme?

    Do I still need to have the twentyfourteen and all plugins off?

    Yes please.

  13. hrrubin
    Member
    Posted 1 year ago #

    Okay, I'm using the 2014 theme, all plugins are off and there is an unpacked 2014 theme in the themes folder.

  14. hrrubin
    Member
    Posted 1 year ago #

    How are you able to help when you don't have access?

  15. esmi
    Forum Moderator
    Posted 1 year ago #

    There's a great deal we can determine by examining the source markup of front end pages. Are you using the US version of WordPress or the Danish version?

  16. hrrubin
    Member
    Posted 1 year ago #

    The danish version.

  17. esmi
    Forum Moderator
    Posted 1 year ago #

    Have you asked on the Danish forums whether anyone is having similar problems with the WP-DK 3.8.1? Looking at your site, it's not what is in the pages that concerns me, it's what isn't. There are no classes being generated on the opening body tag - which is quite bizarre for 2014.

    Do you have any other WP sites hosted on the same physical server?

  18. hrrubin
    Member
    Posted 1 year ago #

    I can see what you mean. Looking at other wp installations, the opening tag has classes.

    I haven't asked them, but I'm going to. This one?

    No other installations on the server.

  19. esmi
    Forum Moderator
    Posted 1 year ago #

    the opening tag has classes

    Exactly! The classes will be different on each page and are generated by the theme's use of the WP core body_class() function. You'll find all of the classes listed here. WP core does use javascript to generate the classes on the fly, so I think you were on the right track by trying to disable script concatenation.

    This one?

    Doesn't look like there's a dedicated Danish forum, so I've no idea where to direct you to try and get feedback from other Danish users. :-(

    Gut instinct is telling me that this is a server issue. Have you spoken to your hosts about it at all?

  20. hrrubin
    Member
    Posted 1 year ago #

    "This one" refering to the danish forum I found.

    I will try asking my host. Thank you for your time. If I find a solution, I will remember to post it here :)

  21. esmi
    Forum Moderator
    Posted 1 year ago #

    One more thought... on some hosting environments, aggressive settings for the "mod_pagespeed" addon can break the javascript code and cause scripts to not be able to function. This can cause many problems, such as widgets not working, menus not being draggable, the customizer not working, or the media screens not being available.

    To fix the issue, your hosts will need to disable mod_pagespeed, or adjust its settings to not take effect in the wp-admin directories.

  22. hrrubin
    Member
    Posted 1 year ago #

    Thank you. I will mention it.

    There seems to be a direct link between watching the site on windows 8 or mac/ipad/android.

    I tested on two windows 8.1 computers, both displaying this problem. Every other device looked normal.

  23. esmi
    Forum Moderator
    Posted 1 year ago #

    I'm seeing symptoms on the front end using Win 7. I think this is far more likely to be a server issue than a browser one.

  24. David-T
    Member
    Posted 1 year ago #

    I'm certain it's a server issue, I have the exact same issue, using same host provider as hrrubin. I've tried everything suggested here, and in my own thread.

    Works fine on my iPad, but tested on 3 different Windows laptops, and the problem is on all of them.

    If you find a solution please write it here hrrubin, I'm having a hard time convincing the host support that the problem is likely to be on their end, hopefully you had more luck talking to them?

    Regardless, I won't stop till I get this solved, and I'll write back here if / when the problem is solved.

  25. hrrubin
    Member
    Posted 1 year ago #

    I'm sad to hear it's not just me. hrrubin.dk uses one.com, however hollywoodpigerne.dk where the problem is, uses dandomain.dk. Regardless, I think it could happen everywhere.

    I guess the best solution is: Don't ever let somebody else install wordpress!

  26. David-T
    Member
    Posted 1 year ago #

    Indeed, but that was the only option for my particular client, when Initially spoke with DanDomain about which subscription would be best, I couldn't get one for him where I could install WordPress myself, unless he chose the much more expensive subscription.

    Which makes no sense to me, regardless of which subscription option you give customers, it should be optional if the developer / designer wants to make his own databases & WP installations, of course (that's how it is on Bluehost / Hostgator!).

    I'm currently getting no help from the host support, they clearly don't know what the issue is and don't seem to want to help.

    I'm giving them 24 hours, then I will take the case up with the director / owners, or as a last resort get Consumer Association involved.

Topic Closed

This topic has been closed to new replies.

About this Topic