Support » Localhost Installs » WordPress could not establish a secure connection to WordPress.org. Please conta

  • priyankac

    (@priyankac)


    Hello,

    We install the latest version of wordpress.org 5.7.2 on the local server (http://localhost/ourtsite).
    After installing WordPress, we trying to install the plugin but it not working we get the error

    1. Warning: An unexpected error occurred. Something may be wrong with WordPress.org or this server’s configuration. If you continue to have problems, please try the support forums. (WordPress could not establish a secure connection to WordPress.org. Please contact your server administrator.) in E:\xampp\htdocs\pro\wp-includes\update.php on line 410

    2. ‘An error occurred while installing Pro Core: Download failed. A valid URL was not provided..’

    How to solve this issue?
    please let us
    Thank You

Viewing 2 replies - 1 through 2 (of 2 total)
  • There are various reasons why the normal mechanisms within WordPress to download and install plugins (and themes) just do not work. These include file system permissions and various system settings. Given that the alternative methods of downloading and installing them on your local file system are so easy, it is simply not worth the effort of getting the WordPress mechanism to work.
    So:
    – Download the relevant .ZIP file for your plugins.
    – Extract them and place the plugin in the wp-content/plugins directory
    Similarly for themes.

    Hi @priyankac,

    Please check the error logs on your server for a more specific error message, which may give a clue as to why this is happening on your website/server. If you need help locating them, ask your hosting provider to help you. If you cannot find error logs or if you don’t find any helpful info in the error logs, enable debugging. See: https://wordpress.org/support/article/debugging-in-wordpress/. Remember to put things back to normal afterward.

    Meanwhile you can also try:

    – Manually resetting your plugins (no dashboard access required). If that resolves the issue, reactivate each one individually until you find the cause.

    – If that does not resolve the issue, access your server via SFTP or FTP, or a file manager in your hosting account’s control panel. Navigate to /wp-content/themes/ and rename the directory of your currently active theme. This will force the default theme to activate and hopefully rule out a theme-specific issue (theme functions can interfere like plugins).

    Hope this helps :)!

    Please let me know if my answer can help you resolve your issue.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘WordPress could not establish a secure connection to WordPress.org. Please conta’ is closed to new replies.